Aeotec Smart Home Hub Setup Failure

The transfer from the V1 hub to the Aeotec hub is not going well. I follow the directions to the letter and still not making it through the setup.

I plug it in. The app detects a new hub. Follow all the instructions and it gets to the downloading updates screen and seems to hang there. It has been 30 minutes and it says 50% (39/79MB). The hub is visible in the IDE. I tried factory resetting and starting over but still the same problem although it stops at different percentages.

Aeotec doesn’t seem to have a phone support option so hoping some wisdom is available here.

When you check the hub in the IDE, what does it show for “Firmware Version”. The hub downloads the firmware update with its own connection and doesn’t rely on the app. It could be that the hub is finishing updating, but the app is just losing track of the hub’s progress.

I factory reset the hub several times. I let it sit for an hour and still did not finish. Finally I got it to work by taking the following steps:

  1. Force stopped the Smartthings Connect app
  2. Cleared cache and data from the Smartthings Connect app
  3. Unplugged the ethernet connection from the Smart Home Hub
  4. Factory reset the Smart Home Hub.
  5. Let the Smart Home Hub sit until the red/green lights were flashing
  6. Opened the Smartthings Connect app and added the hub manually using the wifi connection instead of ethernet.

Success! Not sure which step was the fix but now it is working as expected, I think.

Nice. Glad you got it working,

Couple of updates.

When I was experiencing the frustration of the setup failure I called The Smartest House per the insert that came in the box with the hub. Their voicemail advises someone will call back within a couple of hours on business days. They called back late the next day but I was unable to answer the call. They also followed up with email so I replied to the email explaining the situation. Within and hour they replied that they specialize in the Zwave functionality and I would have to contact SmartThings for my wifi/ethernet issue.

Instead I contacted Aeotec support via email. They responded in less than an hour. The tech that responded advised that swapping between wifi or wired ethernet seems to fix this problem when it comes up. With that said, and the fact that my hub appears to be working correctly now, I don’t believe the hub is defective but rather a firmware issue with the initial setup process.

I’m having issue too. I’ve tried resetting the hub as per the instructions but it doesn’t seem to reset.

I had issues on the same place with the update and then it wasn’t clear if the update was done or not so in SmartThings app I removed the hub and reset the hub as per factory. Since then I cannot get it to flash red/green in order to start the setup again.

What’s interesting is that the hub although not plugged into ethernet is showing up on my network (through wifi). So it’s not resetting I think. I’ve tried about 7 times. (Power off, push in reset, plug power in with reset pushed, orange/yellow light flickers and when it goes solid I stop pushing reset). I’ve tried stop pushing the reset 1 second after turning yellow, 3 seconds, immediately, and about 20 seconds, but nothing resets this darn thing.

What I get now after powering up is alternating solid blue and then alter solid green, then back to blue, repeating. I do not see the hub listed in the IDE either (because I removed it in the app.)

I’ve contacted the Aeotec support, but they have basically told me to do what I’ve already done!

Anyone got suggestions, or had similar problems? This thing seems like a brick, and I just got it.

I unplugged everything from the hub. Used a paperclip to hold down the reset button. Plugged in the power. Kept holding the reset until the light was solid yellow, not flickering yellow. It took about 30 seconds. I deleted the hub from the IDE and it was reset and I was able to make through setup via wifi.

I’ve done that, about 20 times, and doesn’t reset.

Have you tried connecting via ethernet? What’s your hub’s serial number?

Yes. Same thing. Even without connecting it connects to my wifi but I don’t see it in the SmartThings app nor on the IDE ( Resetting doesn’t reset and I never get the flashing red/green lights.

Brad, I believe the tech from Aeotec has a ticket into ST, but not heard back from him. He’s given the details (incl serial number).

Oh, I see a reply from the Aeotec tech. He advised plugging into router and doing reset and waiting up to an hour for an update. Trying that now.

Same result plugged in. Interestingly enough when connect to my wifi it downloaded about 6.3GB for the day it was plugged in and left on wifi. When plugged into router the usage on my router shows the hub downloading 4.0GB since 7pm to now 9am. Very odd, extremely high download numbers.

The tech says they may just need to replace the hub. I’m wondering if ST can’t just enable from their side and add it, then push new software through and all will be good again? But will the reset ability still not work (although I don’t have a need for that often).

what brand is the router? have you tried rebooting it?

It’s the new Aeotec smart home hub, which seems to be a rebranded ST v3 hub. Rebooted many many times, reset many many times. Seems Aeotec support is in contact with ST support.

no, what router are you plugging it into?

Google wifi router

3 pucks? are you connected to the main one when plugging into ethernet?

That’s correct, 3 pucks, plugged directly into main one.

@RobM Can you try the factory reset and activation one more time? If that fails, I think I can manually correct things without the need to replace the hub.

Starting now.