Aeotec Smart Home Hub/2018/2015 Model Hub Firmware Release Notes - 0.38.10

Very annoying for you, I’m sure JD may have some thoughts if he is available at some point

Il try a few more Alexa integrations to see if I can replicate your issues but hazarding a guess if one works they probably all work

Bit more difficult to figure out which automation is from ST to alexa but from what I can tell I seem to be having no issues

What DTH are you using for the virtual devices? Mine are also working OK, for what that’s worth. Did you report it to smartthings support?

@KyleStilkey have you tried rebooting your hub?

3 Likes

Suppose its early days (1 week in) but I’ve just ditched Smartthings for Hubitat, and i should have done it ages ago. (80+ devices, Zigbee, z-wave, sonos and RF433).

All of my old device handlers work in Hubitat (the ones that stopped working when they switched off the old app.)

The hubitat app instantly knows the status of my devices, where the samsung app needed to think about it for up to 60 seconds. (which made the ST app useless, I needed to use action tiles to control my lights).

The hubitat alarm is far more customisable.

---- appeal to Smartthings ------

You use to be brilliant, then you started, switching capability off, slowing things down (slowing things down probably not intentional but a fact), insist on stuff being handled through the cloud, stifled the innovation and creativity of your users which has compromised your offering. (defo stop considering switching off the IDE)

The / your platform would not have got off the ground without those early adopters, now those people are leaving your platform on mass; to create, innovate as well as maintain their privacy. Granted you are left with a load of people that have purchased your hub and a few of your devices to solve a problem ( i was one of them) however, those early adopters that are creating their own platforms that do everything yours did and more (and private / locally - Fast). Unfortunately (for smartthings) they are now making those platforms, ie Hubitat, as easy to use as smartthings and eventually the people who just want to solve a problem will switch (again, i am one of them), or new customers who just want to solve a problem won’t start with SmartThings.

So back to my appeal, ST you need to listen to your users, or you will lose them. ie fix peoples gripes and issues; there is a starting point above - fix Alexa problems.

I would love to have 1/2 hour with your strategy director - you could be so, so great yet you continually un-invent things. You started great and through all of the cloud data you hold you must be able to see the users jumping off of your platform.

RIP

My story in summary, Im not a tech guy:

  • purchased smartthings hub to fix a simple problem, loved the results
  • Purchased some smart lighting plugged it in to SM Loved the results
  • Bought smart locks, window sensors, motion sensors used in ST and loved the results
  • All lighting, locks and alarm system managed by ST
  • Samsung remove a load of device handlers, messes up my system and i lose a load of devices
  • New app so slow virtually unusable
  • Tried HA, realised i needed to have a degree in programming and gave up.
  • Switch to Hubitat, easy to set up, everything works again, inc old devices that SM prevented, instantly within the app, automations replace (and amazed by the easiness of the conditions and customisations).

Once your users who just want to solve a simple problem realise they can set up systems like hubitat, you will lose them if you don’t listen to them.

Credit where it is due your app is pretty, but i want stuff to work and i want to see its status in real time. Ditch the prettiness for functionality and usability (like you old app, it wasn’t pretty but it worked and had more functionality then your new app - how is that moving forwards?).

Last comment from me, I’m only commenting on this forum because of the e-mail i received notifying me that you are updating the firmware and fixing some bugs that you never tell us about. You need to communicate properly.

All the best for the future.

5 Likes

My hub updated at about 11AM PDT. Since that time NO devices have logged anything.
They seem to work, my virtual presence switches update, but “History” is blank on both the API site (https://graph.api.smartthings.com/) and on my IOS app.

(Yes, I’ve re-booted the hub and the IOS app.)

Please fix this!
Thanks

1 Like

Based on my hub log I believe I received this update today. I have a 2015 (Hub V2). 2 minutes and 57 seconds after successful update my hub disconnected and became inactive. Since I have rebooted, changed ethernet cables, moved hub to different plug. Nothing works. Did this update brick my hub?

did you tr powering it off and removing the batteries for several minutes?

also, contact ST support

Same here. History has not updated since about 11a PDT, for any devices.

Same here too. I have both Android and iOS devices and even though everything seems to be working, the SmartThings app isn’t showing anything in either History, Device History, or Notifications.

And, I just checked the IDE, and hardly anything is being logged there either.

Same hear. No history since about 1 PM EDST on Monday. Everything seems to be working.

Same here. No history and my virtual Alexa switches stopped triggering routines that were working well just before the firmware update…

Yes, was the first thing I did. I can see others were having issues now as well. I’ve been at work, but off and on looking through stuff and see that the activities/event logs show nothing at all. The device shows as getting the update, update is successfully installed and then nothing. Just dead, not even my motion detection work, nothing is triggering an event.

I can see the app shows activities for the devices but it seems to not actually be triggering anything. I’m unsure of its the firmware update that is the cause or possibly something else was also changed on the backend at this time as well and broke some things.

Either way I hope this gets looked into. I’ll reach out to support and see what they think but I tend to just get the run around restart, unplug reset routine, unless there is somewhere else I should be reaching out to, I’ve not had good experience with support really lol.

1 Like

My hub updated to the latest version and now the hub doesnt work , did the new update brick it , its a v3 smartthings hub and i did try to reset it for 5-6 times , no change , device disconnects everytime the update is done after the reset, i get a solid blue light with a flickering green light with half a second delay.

Checking History, Device History, and Notifications this morning, it seems to be partially coming back. All of the Notification history is now showing. Device History isn’t quite up to date or even live though, and History is showing live Automations triggers, but no up to date or live Device History.

1 Like

Turns out my updated hub didnt like my smartapps and device type handlers , deleting them in the ide , setting up the hub again and re installing the smartapps and the dth’s fixed my issue

Oh man oh man things are just getting worse and worse. WTH is going on with ST!!! Updates should not brick hubs, disconnect devices, take away useful features, make Apps unusable, totally f up stability (if there was ever a thing), make things slower, and basically…make people hate the platform and jump ship!

Maybe, just maybe, that is the end goal! F up as much as possible so people leave the platform and they can cater to those who just want to check the status of their appliances!

Have we all been duped?

I’m still hoping that we will all come out of this thing with a better product but…

3 Likes

I’m still having a multitude of issues with the update. Spent a couple of hours trying to make sense of what was wrong then found this thread. Running a 2015 v2 hub. Multiple devices of different types reporting as offline: z-wave leak detectors-all the same type/brand some online some not, GE plug offline but can trigger from event, Smartthings multi-sensor buttons some work some don’t, trying to view Smartthings door sensor in IDE and get “Error
500: Internal Server Error
URI
/device/show/93342f55-d098-40fb-b795-e06c16896148
Reference Id
37b3bbbb-5cbd-4e78-a479-e81044019ae3
Date
Tue Aug 03 21:11:54 UTC 2021.” Events don’t trigger consistently. I’ve powered my hub down (pulled cable, batteries, e-net cable) a couple of times for 30 minutes stuff still not working. Can I get the old firmware back?! Standard software/firmware practice when you hose stuff up is to roll it back.

Contacted ST Support; they walked me through factory reset (which I knew how to do and was hoping to avoid). Did it twice. Still nothing. Red light of death. Was told basically my V2 hub was old and I needed to get a new one. I asked if the update pushed to the hub ONE MINUTE before it died could have had an impact and was told “No”. Not ideal customer support. The update killed my hub.

It turns out that my hub is actually (partly) working. The device status and automations seem to be OK, but logging and history is about 6-8 hours delayed.
So - not totally broken, but still way not good!

Update to earlier post.

Got everything back online. Not sure if all me, or voodoo. Another power down reset (3 or 4 total) of hub then I did have to wrangle my Z-Wave Water Sensors (model TS0207) though to get them online. After some tries this is what I did to make them work. I edited each sensor to switch the DH from “Z-Wave Water Sensor” (correct DH) to “Z-Wave Sensor”, did an update, waited a minute or two then switch it back. Weirdness is I had to click on “Current States” parms "battery and “water” after switching back to view them before the sensor popped back online. Maybe a polling thing but still weird. Some logging is still slow but mostly working.