Aeotec Smart Home Hub/2018/2015 Model Hub Firmware Release Notes - 0.37.04

We will begin rolling out Samsung SmartThings Hub firmware version 0.37.04 starting Monday, June 14th. Once downloaded, your Hub will briefly go offline as it reboots and applies the update; most customers will experience less than one minute of downtime. We will update the status page when the release is complete.

Hub Target:

  • Samsung SmartThings Hub 2015 (Hub v2)
  • Samsung SmartThings Hub 2018 (Hub v3)
  • Aeotec Smart Home Hub

Release Date: 14 June 2021 ~ 18 June 2021

Note that this release may be spread out over a week, so you may not see your Hub update the first day of the release period.

Release Notes

Features

Zigbee Enhancements

  • Firmware update for the Schlage BE468GB

Z-Wave Enhancements

  • Auto “Ghost Node” Cleanup – ”Ghost Nodes” are Z-Wave Nodes that do not match with a device that exists in the SmartThings App. When a Ghost Node is removed, a hub event is observable in the SmartThings IDE: zw removed device: XX, where XX is the Z-Wave Node of the removed Ghost Node. Ghost Node deletion starts within 24 hours of a hub reboot or update and occurs periodically.

Bug Fixes

  • Minor bug fixes and improvements
4 Likes

ohhhhhhh new say!

Where does this leave the Smartthings WiFi here in Australia.
Will it continue to be updated?
I notice that Aeotec give migration paths for V2 and V3 but no mention of WiFi version?

This doesn’t mention anything about the ikea zigbee battery drain issue being resolved…unless smartthings categorise that as minor fix…seriously?

1 Like

SmartThings WiFi updates usually come a month or two after the normal hubs. Last one was about 3 weeks ago.

1 Like

This is NOT a SmartThings only issue - it’s being reported on Zigbee 3.0 stacks on ST, HA and a few other platforms as well. I STRONGLY suspect it’s an Ikea problem in interoperating with Zigbee 3.0 - which means it’s Ikea’s problem to fix. ST just exposed it when they upgraded the Zigbee stack. Don’t expect it to be fixed fast at all…

2 Likes

According to ST support they are working on it though and ‘making progress’…

Ikea 5 button remote killing batteries

So maybe?

1 Like

“Working on it” could be telling ikea to make new firmware that fixes it or putting a workaround in the hub firmware. If it’s the former it could take a while.

2 Likes

the Zwave ghost node indeed drove me crazy a little, it would be nice to clear that up finally.

Unfortunately the status message says it started on Wednesday 9th …

Ive had 2 texts this afternoon, im sure the first one mentioned a firmware 05 at the end, its now back to 04
Something odd going on here

At around 3 uk time

I have the Hub 2018 (Hub v3) and it’s still on 35.4. Shouldn’t it have been updated by now?

I have an Aeotec Hub (V3), checked this AM and was on the 35.xx firmware…

Just checked my hub again and I’m on the 37.04 firmware… Happened sometime today. :man_shrugging:

I have the same hub and mine is updated as well. The last time I checked was a few days ago. Now just waiting for the new app update on iOS.

1 Like

Contact ST support and open a ticket…

Support@smartthings.com if US

Also, login to IDE and confirm the hub shows the older firmware there.

I have the pleasantries of figuring out why ALL of my Phillips LED’s stopped working today (Hub updated … today … ) and my thermostat fell off also. The IDE shows the LEDs checking in …
“[Kitchen LED 2] ZigBee RGBW Bulb xxxxxxxxxxx xxxx ONLINE” Local moments ago

Thermostat simply says 'Offline" now, and is no longer listed in the IDE, i.e. totally gone. Button in app is still around though, but offline. Buttons for LEDs are present also and ‘appear’ to register when turned on/off.

This new app is proving to be trash … again. :frowning:
Going to reboot it again, even though the firmware has appeared to do just that today. I’d rather not have to re-add a bunch of things :(.

2 Likes

Eho’, hard restart ftw. Better than re-adding things. However, not ideal if I was out of town.

Not to be an ass and leave nothing, here is what I have and firmware:

Status ACTIVE
Firmware Version 000.037.00004
Hardware Version Hub v2 US

Lastly, this is the first time in around five years i’ve unplugged this thing. Its been living on a rather large data rack UPS, and has never had power interrupted. It HAS rebooted for firmware updates regularly, but never a hard power down. To be fair, that isn’t horrible for a device at all.

WOW! I can’t toggle any of my virtual switches when I got home today. I did notice they pushed that latest firmware update to my SmartThings Hub while I was out. I guess I’ll try rebooting the Hub to see if I can get my virtual switches to work again.

Hum, I got in the IDE to reboot the Hub, but it didn’t work. The SmartThings app still works since I can toggle STHM, and all of my physical devices. Just not the virtual switches. Funny thing is I can toggle the Alexa virtual switches. Weird!

After I power cycle it, my virtual switches are working again. Strange…

1 Like

Immediately subsequent to the firmware update I received yesterday, Smarthings lost the ability to control any and all of my connected smart lights and associated automations. The reporting shows online for each device, but once actions are run in the app or via IFFT, the action is not performed.

Update:
Hard reset seems to have fixed it - i.e. pulling out batteries and such.