Aeotec Home Energy Meter Gen 5 - only Manual Refresh of Meter Readings work

Hi. Sharing here that the current installation of the Aeotec Home Energy Meter Gen 5 updates meter reading when manually refreshed at Seeking advise and inputs from the community if there are configurations or work around that will make the device auto update periodically

I would suggest contacting Aeotec support

What driver you got? There´s at least 3 drivers that works fine with mine HEM: beta channel driver, Aeotecs own driver and Mark-Johnstons driver that I´ve been using lately (I like it because it shows total energy consumption in icon instead of momentary consumption). Readings should also update automatically in matter of seconds.

1 Like

I’m using Aeotec’s driver. will search for the mark johnstons driver and use that. thanks.

Posting the link here for anyone on the same situation - My Edge Driver for Aeotec Home Energy Monitor Gen 5 (3 clamps)

hello robby,

I bought an aeotec Hem gen5 yesterday and noticed the same thing. Meter reading updates are not updated automatically. I used all the drivers I could find:

Aeotec official,
smartthings beta,
mark Johnson,

but the behavior is the same.

Do you have the solution? Thank you

Hi, sorry for the late reply. If you haven’t fixed it, this is how i solved mine. It’s now working and displaying demand and energy consumption in real time.

I switched drivers between the Mark Johnston driver and the Aeotec driver and reinstalled the edge drivers for Aeotec. It’s now working using the Aeotec driver. On settings, i’m using “3” for the 101 Sensor reports and using “60” for the 111 Group 1 sensor report time. I like that the Aeotec displays the demand in kW on the dashboard instead of energy in kWh.

When you make it work, i also recommend using it with Constant Graph. That website provides data sync and nice visualization on your energy monitoring.

Hello robie, sorry i didn’t understand your solution.

Now are you using the aeotec official driver?

Hi Robie,

I tried a few different methods and I would like to check the procedure with you as I not able to get the live reading.

I have the Aeotec hub with SmartThink apps

  1. I add the Aeotec gen5 meter.
  2. Instal the age drive Aeotec gen5 2 clams
  3. Setting - 101 “3” and 111 “60”

With this setting I should be able to see actual readings every 60 seconds. But if you go the device history is not updating every 60 seconds.

If I manually refresh the device scrolling the scree I get reading update.

I went back and forward with the 3 drives:

  1. Aeotec home meter gen 5
  2. Aeotec home meter gen 5 2 clams
  3. Smartthing Zwave Energy Meter

Non on them are able to update without refreshing.

Solved. Use the Age driver from Aeotec for 2 clams. Use parameter 101 = 6015 and 111 = 60
Make sure to add association = 01