Aeotec by Aeon Labs ZW096 Smart Switch


(John) #1

Hello, I have a Aeotec by Aeon Labs ZW096 Smart Switch that I use in my garage to ensure my EV charges during the times I get cheaper electric rates and to track my electricity costs for charging my car. The problem I am having is the reset KWh button in ST doesn’t work. I also tried using a webCoRE piston but that won’t reset the KWh back to zero either.

Anyone else having this issue?


#2

Who’s DTH are you using? ST’s stock, or a custom handler?


(John) #3

ST’s stock


#4

Ok, thanks.

You probably need a custom DTH:


(John) #5

Thanks, but this looks like it is for gen 5 and I have gen 6.


#6

It’s actually the “Switch 6, Gen 5.”


(John) #7

Hmmm…Ok. I must have a different device. I installed the DTH and it didn’t update my switch in ST.

https://www.amazon.com/gp/product/B00VQISOCG/


#8

The device you linked to is the Switch 6, Gen 5. There is no Gen 6.

Can you explain a little more on what didn’t update. Are you saying the values are not updating? Not resetting?


(John) #9

After installing the DTH and opening the switch in ST the interface is still the stock interface.


#10

Okay, then the custom handler is not installed properly. Have you gone in to the My Devices in the IDE and edited the device to change to the newly installed handler?


(John) #11

Oh come on. I’ve been installing custom DTH’s for 1.5 years and I completely spaced the fact that I have to change the handler for the device!! Ugh. That’s why I could never get your Minimote DTH to work. :roll_eyes:

Thanks @Nezmo


#12

Glad you have it working!