Aeon Multi-Sensor

Searching didn’t reveal the answer so…

I’ve got the subject sensor installed and all the readings seem to be working. Should the “Configure” tile do something when pressed?

What do you mean by Configure Tile? I just pressing the mutli-sensor tile in the matrix, or are you pressing the setting gear in the lower right corner of the tile in the matrix? Or are you already inside the sensor’s settings tiles and have a tile that says: “configure”?

My understanding is that the configure tile is basically a force update of the readings. I believe it is mostly for initial setup.

Bob Florian replied 6 days, 2 hours ago
The Configure button instructs the device to send temperature, relative humidity, and illuminance reports every 5 minutes. That also happens when the device is initially paired, but if the device gets reset to factor settings for some reason, the Configure button restores the settings that SmartApps expect from the device.

Z-Wave devices can be told how to report in, when the device pairs it is automatically sent the configuration command which tells it how often to report in certain values. SO it sends temperature, humidity, light and different intervals. That tile will resend all the configuration commands that we came up with for optimal battery life.

Thanks everyone for your comments. Are the configurations values documented anywhere and can they be adjusted by the user?

I’ve been wondering about the default times. From the logs, mine appears to be polling the Temp, Humidity, etc every 8 minutes. The motion is resetting every 14 seconds. The poll time is fine but I would like the motion to last a lot longer before resetting.

Mine give me incorrect temperature readings consistently. Actual temp 84F, Aeon 1 78.5. Aeon 2 77.5. I’ll try setting up a couple mote but really disappointed. For 50 bucks you’d think it would have better accuracy. Just sayin. Humidity however appears to be close to actual. lux is a whole different issue. Checked against a real lux meter it’s not even close.

My sensor is reporting very erratically. Pasted below is the last ~23 hours. It pretty much fell asleep for a while then magically woke up and reported temp and humidity. No motion despite me working around it a couple hours back.

One thing I wonder about is the range of the device and antenna of the ST hub. Although neither moved, perhaps connectivity is an issue? Any thoughts?

ID Date Source Name Value Displayed Text Raw Description Displayed State Change
36c7cf0d-a6aa-42a9-9e96-8219f21581fc 22 Jul 2013 15:47:21 - moments ago DEVICE temperature 79.7 Aeon Multisensor temperature is 79.7°F zw device: 03, command: 3105, payload: 01 2A 03 1D true true
ffdfcd4b-c361-48ec-9e74-5a761afb40c7 22 Jul 2013 15:47:21 - moments ago DEVICE humidity 58 Aeon Multisensor humidity is 58% zw device: 03, command: 3105, payload: 05 01 3A 00 true true
e8555939-3f79-483d-8ad2-84e3a5dcee2c 22 Jul 2013 15:39:21 - 10 minutes ago DEVICE temperature 78.8 Aeon Multisensor temperature is 78.8°F zw device: 03, command: 3105, payload: 01 2A 03 14 true true
3e7a1fc0-2986-464c-a375-fe02afe0591d 22 Jul 2013 15:39:21 - 10 minutes ago DEVICE humidity 59 Aeon Multisensor humidity is 59% zw device: 03, command: 3105, payload: 05 01 3B 00 true true
489801d4-d33c-4e06-a2f7-74592f1f9bb8 22 Jul 2013 15:39:20 - 10 minutes ago DEVICE illuminance 1000 Aeon Multisensor illuminance is 1000 lux zw device: 03, command: 3105, payload: 03 0A 03 E8 true true
240e9d67-fb90-465f-b800-bf757fd0cccc 21 Jul 2013 16:26:51 - 23 hours ago DEVICE motion active Aeon Multisensor motion detected zw device: 03, command: 3003, payload: FF true true
2f00284a-2807-4c8d-ade1-05a5851e6055 21 Jul 2013 16:26:50 - 23 hours ago DEVICE motion inactive Aeon Multisensor motion has stopped zw device: 03, command: 3003, payload: 00 true true
cef0c741-2285-4e6e-a8c6-f0105e718234 21 Jul 2013 16:26:35 - 23 hours ago DEVICE motion active Aeon Multisensor motion detected zw device: 03, command: 3003, payload: FF true true
a2b648b2-3b7a-40f5-b8f3-9362a02e29f4 21 Jul 2013 16:26:13 - 23 hours ago DEVICE temperature 75.2 Aeon Multisensor temperature is 75.2°F zw device: 03, command: 3105, payload: 01 2A 02 F0 true true
c18f73b9-0c57-4f63-81c9-a9141616b8ba 21 Jul 2013 16:26:13 - 23 hours ago DEVICE humidity 63 Aeon Multisensor humidity is 63% zw device: 03, command: 3105, payload: 05 01 3F 00 true true

I’m having the same issues here.

The motion detector seems to be polling every 15-30 seconds which seems like a huge waste and clutters the activity stream. I’ve tried selecting the configure button, but no luck. Any help?

Also, lux has a “0” readout.

The illuminance sensor intermittently works (not a big deal since I don’t use it).
The bigger issue is the polling after motion is detected. It sends a motion-off signal after 15 seconds, and then checks for motion again. This in my opinion is way to short. I’ve already gone down to 95% battery in 24 hours.

I was able to replicate the device type by duplicating the multisensor code; however, the configure button doesn’t seem to work. I adjusted the values in the code (from 15 secs to 240secs), republished and assign to the device. Supposedly, when I select the configure button, it should reconfig the polling time after motion has been detected.

@urman - help please.

@thegibertchan that value you see in the code isn’t how often it checks in with motion, it’s how long the motion event lasts on the device. So when it senses motion it takes 15 seconds for it to stop sending motion. If you wanted to send the configuration commands again the push the black button on the inside of the Aeon Multi then immediate hit the configure button.

1 Like

@urman, let me try to understand this correctly.

Currently my aeon multisensor will send a “active” event when there’s motion detected, and if within 15 seconds there’s no motion, it’ll send a “inactive event”.
I would like to prolong this delay so that it waits 3 minutes (or keeps checking for motion) before sending an “inactive” event.

I’ve tried altering the device type code on the following line to do this:
zwave.configurationV1.configurationSet(parameterNumber: 3, size: 2, scaledConfigurationValue: 15).format(),

Changing from 15 to 180

After altering the code I would use the configuration button to send this command. When I’ve tried this, it doesn’t change the settings.
I’ve tried pressing the button once, then config. I’ve tried pressing it 3 times then config. No change…

Am I doing something wrong?

Got it to work.

Not sure what I did differently, but I repeated the steps and was able to change it to a 4 minute interval before sending inactive message.

Thanks @urman.

@thegibertchan the trick it to make sure the device is set to use the handler you made. Then timing the clicking of the button (wake it up) and hitting the configuration tile. If the Aeon is plugged in then it should always respond to the configuration and not need to be woken up first.

This is still a learning experience for me. For me it is ideal to poll light levels every 3 minutes, temperature and humidity every 10 minutes and motions at the recommended rate. So how does one manage the configuration options and control custom values. Id there supporting documentation?

There’s no documentation that I can think of but you can do the same that I did, modify the Device Type Code.

Open the ST IDE create a new device type, and copy the code from Aeon Multi Sensor. Once you do that, scroll to the bottom and edit the following line:

zwave.configurationV1.configurationSet(parameterNumber: 3, size: 2, scaledConfigurationValue: 15).format(),

Change the scaledConfigurationValue to the amount of seconds you want till it checks agin for movement.
Same goes for the following lines if you want to change the polling time for temp/humidity and luminance.

// set data reporting period to 5 minutes
zwave.configurationV1.configurationSet(parameterNumber: 111, size: 4, scaledConfigurationValue: 300).format()

That line at the end is the value in seconds you will want to use. 300 is the value in seconds.

Change that, save/publish the device, change the device type, open up the SmartThings app and go to the aeon multi’s tile, press the button on the aeon multi and then hit configure in the tile to send the new commands.

Is there any way to get some of these modifications into the official Aeon Multi device type? I made some changes and the battery life is still pretty abysmal. From 65% to 11% over 5 days.

Why not make this a configurable item in the Preferences?

I do have a question about Configuration. My understanding is that most battery operated z-wave devices are sleeping and not actively listening. When pressing “Configuration” and sending the z-wave commands to the z-wave device, will the device actually execute these commands?

Or should the code be changed to defer the execution of configure() until the device wakes up?