AEON Home Henergy Monitor V1 Sample rate - Dryer Monitor

I’m trying to monitor my dryer and create alerts when it is done. Since it is a 220V device, I need the capability of the Aeon HEM to measure the power. Unfortunately, the power measurement of my HEM Version 1 occurs every 5 minutes, and my dryer has a 1 hour “wrinkle protection” that spins the drum…every 5 minutes… so I can’t get it to register the end of cycle until the wrinkle protection is over. If I could sample every minute or less, it would work.

I’ve seen folks claim they have adjusted their device. No luck here. Can anyone help?
I created a new drvice type from the AEON HEMV1 and changed the following.

def configure() {
def cmd = delayBetween([
zwave.configurationV1.configurationSet(parameterNumber: 3, size: 1, scaledConfigurationValue: 0).format(), // Disable selective reporting, so always update based on schedule below <set to 1 to reduce network traffic>
zwave.configurationV1.configurationSet(parameterNumber: 4, size: 2, scaledConfigurationValue: 50).format(), // (DISABLED by first option) Don’t send unless watts have changed by 50
zwave.configurationV1.configurationSet(parameterNumber: 8, size: 1, scaledConfigurationValue: 10).format(), // (DISABLED by first option) Or by 10%
zwave.configurationV1.configurationSet(parameterNumber: 101, size: 4, scaledConfigurationValue: 4).format(), // Combined energy in Watts
zwave.configurationV1.configurationSet(parameterNumber: 111, size: 4, scaledConfigurationValue: 15).format(), // Every 15 Seconds (for Watts)
zwave.configurationV1.configurationSet(parameterNumber: 102, size: 4, scaledConfigurationValue: 8).format(), // Combined energy in kWh
zwave.configurationV1.configurationSet(parameterNumber: 112, size: 4, scaledConfigurationValue: 60).format(), // every 60 seconds (for kWh)
zwave.configurationV1.configurationSet(parameterNumber: 103, size: 4, scaledConfigurationValue: 0).format(), // Disable report 3
zwave.configurationV1.configurationSet(parameterNumber: 113, size: 4, scaledConfigurationValue: 0).format() // Disable report 3

Didn’t make a difference. Anyone have any suggestions?

I have one and it polls every 5 seconds. HeMv2+ device handler

So V2 will poll at 5 seconds. Any hope for my V1?


Run the HEM v1 on A/C power should give you faster polling.

1 Like

Thanks, but already on AC.

change your device handler

1 Like

Hi @robj,

I’m not sure who’s device handler you may be using, but try mine here:

After changing your device to use this in the IDE, make sure to tap on the Configure tile in the app. Also, make sure that within Preferences that you have a value for cost. It can be anything you like, including 0.

This device handler will force the HEM to report every 15 seconds, which you can adjust by changing line 247 to what ever you need. 15 seconds should be more than enough.

Looking at what you posted above, that should work too. Did you tap on the configure tile in the app after trying yours?


@robj Make sure you go into the device in the SmartThings app and hit the “Configure” icon after you have changed the device type in the IDE.

Edit: looks like @johnconstantelo beat me to it by a few seconds. :stuck_out_tongue:

1 Like

Got it going!!! Many thanks everyone.