Aeon Home Energy Meter Device Handler - Qubino Meter

Hi all,

I am testing the Qubino Smart Meter which uses the default device handler of the Aeon Home Energy Meter. In the configuration parameters in the device handler, parameters 40 and 42 are set. Parameter 40 is the percentage change in watts on when to report the device enrgy status. Parameter 42 is the time interval on when to report the devices energy status. The snippet of code in the device handler is shown below. The isQubinoSmartMeter() just tests if this is the Qubino meter as this handler is used for a few meters, it returns true in my use case.

else if (isQubinoSmartMeter())
				encap(zwave.configurationV1.configurationSet(parameterNumber: 40, size: 1, scaledConfigurationValue: 10)), // Device will report on 10% power change
				encap(zwave.configurationV1.configurationSet(parameterNumber: 42, size: 2, scaledConfigurationValue: 300)), // report every 5 minutes

In the above code the device is set to report every 5 minutes (300 seconds), however this is where I am a bit confused.

According to the technical spec issued by Qubino this parameter can have a value from 1- 32535 seconds.

According to the user manual this parameter can have a value from 60-32535, setting the value to 0-59 disables reporting and the default value is 10 minutes.

According to the z-wave alliance default value 600 (10 minutes), 0-599 = reporting disabled, 600 - 32535 = 600 seconds - 32535 seconds.

I cannot get this device to report on a set time interval at all and I am unsure which values are even valid now. Testing the default of 600 does not work either with the default device handler it seems. I have contacted Qubino to ask them but I am wondering if anyone has got this parameter working or where the reference of 300 in the default device handler has come from?

Any help is appreciated!

I see your point regarding confusion, indeed it is.

But as the phrase says, The Proof Is in the Pudding

You need to understand first what are those parameters mean,

Parameter 40 - Report on change - The device will report any change if it is more than 10% power change. So from changing from 100 W to 120 W it will report.

Parameter 42 - Report by time - This means, the device will report a value every X seconds, if there wasn’t any report since. (I do an assumption here with the if statement, but some devices do report every X seconds if there was or wasn’t any report since.) The point of this kind of reporting to show that the device is still connected and works. And for reporting smaller changes. Usually the reported values are logged in some setups and can be used to calculate a consumption for the whole day, week or month by integrating the recorded values.

You should de a test to read back the configured values from the device just to confirm that they are working, and to keep the device running without any load change for the time period.
And meanwhile use live logging to debug the reports. Here to note, if the value is not changing and an event is sent by the DH, it will have an isStateChange false flag and no new event will be logged. If you want to force the DH to log a new event every time when a new value is received you need to for isStateChange true for the event.

I hope it helps until you get some reply from Qubino.

1 Like

Of course there can be differences of handling parameters between different firmware versions of the device.

@johnconstantelo developed a DH for the HEM before, he can give more advise maybe.

Thanks for tagging me @GSzabados. I saw this post earlier, as well as the other thread. I can feel @Warren1’s frustration when I see 3 documents referencing the same setting all have different descriptions and/or definitions.

I’d read the tech spec as it’s written. Acceptable values are as stated, but how ranges within that spec are managed/handled should be addressed in the user manual. Unfortunately, we can all see there’s a discrepancy between the manual and z-wave alliance’s document. I suspect some sort of typo on Qubino’s part.

I think clarification from them is definitely needed, but the comments you’ve provided are spot on. Fortunately for me, Aeon’s documentation for their HEM was spot on.


Hi @GSzabados,

Thanks for the reply. The setup I have currently is held at a constant load, the value of watts is not changing. I am reading the values manually using a refresh command which is shown below to test if the meter is actually responding. I am getting values from the meter using this function.

def refresh() {
	log.debug "refresh()..."
    		// Change back to encap
			crcEncap(zwave.associationV2.associationRemove(groupingIdentifier: 1, nodeId:[])), // Refresh Node ID in Group 1
   			crcEncap(zwave.associationV2.associationSet(groupingIdentifier: 1, nodeId:zwaveHubNodeId)), //Assign Node ID of SmartThings to Group 1
			crcEncap(zwave.meterV3.meterGet(scale: 0)), //kwh
			crcEncap(zwave.meterV3.meterGet(scale: 2)), //Watts 
            crcEncap(zwave.meterV3.meterGet(scale: 4)), //Voltage 
            crcEncap(zwave.meterV3.meterGet(scale: 5))  //Amps

The meter has never reported due to a change in watts as it has never changed from a state of 0 W. I do have a load on it which is strange that is recording a value of 0W. I connected it up to an Aeotec Smart Switch 6 and the Aeotec plug is reporting a value of 1 W but the meter is reporting a value of 0 W. Values of Voltage and Current can be obtained which look correct but always have to be manually polled, the parameter 42 does not function at all unfortunately.

@Warren1 - Ok, here is what I think…

Minimum current (Imin):	0.25 A

That is from Qubino’s website.

What is the real consumption of that device? 4 Watt is correct? I cannot assume it, but de an easy test, change that device to a light bulb. Better to use and old 100 W bulb to have a decent reference load, or even better, plug in a vacuum cleaner, that will show you the load. :wink:

Do your test with a decent load…

1 Like

@GSzabados have an bulb attached to it now and it is reporting values of watts, thank for this solved that problem.

In regards to the timing I have experimented a bit with it, I set parameter 40 to report only on 100% change which in my case was never really as I just kept the bulb on. It seems the minimum reporting value for this meter at regular intervals is 60 seconds. If it is set to anything below 60 seconds it will still report every 60 seconds except when it is set to 0 . Think the approach I will take is setting parameter 40 low and keeping parameter 42 at 60 seconds to ensure it is updated at least every minute.

Thank you @GSzabados

For anyone else that stumbles across this and wondering about parameter 42 for this meter this sums up what I found:

0 = Reporting off
1-60 = Report every 60 seconds
61-32535 = Report every 61 to 32535 seconds
These time intervals are from when the last report was sent.

1 Like

Please edit this to 42.

If anyone is using the Qubino Meter please read this Odd commands being generated