Aeon Micro Smart Energy Switch--how to change parameters?


(Nico) #1

I have Aeon Micro Smart Energy Switch 2nd edition (DSC18103-ZWUS).
I already connected to ST hub, normally work, switch and energy reporting.

But, I have a problem with energy reporting interval. By default, using “Aeon Outlet” device type, energy reporting is every 300 second.

def configure() {
delayBetween([
zwave.configurationV1.configurationSet(parameterNumber: 101, size: 4, scaledConfigurationValue: 8).format(), // energy in kWh
zwave.configurationV1.configurationSet(parameterNumber: 111, size: 4, scaledConfigurationValue: 300).format(), // every 5 min
zwave.configurationV1.configurationSet(parameterNumber: 102, size: 4, scaledConfigurationValue: 0).format(),
zwave.configurationV1.configurationSet(parameterNumber: 103, size: 4, scaledConfigurationValue: 0).format()
])

with default, everything works fine, energy report it’s value every 300 second, here’s the log :

I’m also able to change it reporting interval, for example, 200 second

310 second

But strangely, I can’t change the value far bigger.
I change the interval to 480 second, here’s what happen

The interval time / delta time is not right. Never 480 second. it divided into to reporting interval.
120 s and 360 s . 115 s and 365 s

I try change bigger value, 720 second
here’s the log

for me, reporting KWH every 5 minutes is too fast, no need that kind of reporting.
Reporting energy usage every 4-6 hours, is more than enough.

How do I change the reporting interval for this device ?


(Nico) #2

Hello @april I just contact support via email, but he/she can’t help me out with this. Then he/she suggest to mention you to take a look with this


#3

I’m sorry, my text reader can’t read your logs, so I can’t see specifically what’s happening.

One possible issue: Aeon allows for signed values, which means you sometimes have to send a negative number to get a large positive one.

Their European documentation is much better at listing parameters, for example. See if this gives you any ideas.

http://www.vesternet.com/downloads/dl/file/id/62/z_wave_aeon_labs_micro_smart_energy_illuminator_manual.pdf


#4

Also this developer’s doc has an example:

http://www.pepper1.net/zwavedb/uploads/resources/1f5c804cf92d4797dda2d142a452035ba0aefe99.pdf


(Nico) #5

I have same product documentation like you give.
I see the parameter number 111 (for interval reporting) value is 0 - 65535 , and default value is 720

Default ST value is 300, which means 300 second.
Should I use negative value when the size is 4 byte and the max value is 65535 ?

the reporting interval gone wrong when I just change to 360 second interval

I never try to write the hex code, let me try


#6

I’m sorry, I don’t know where SmartThings does the hex conversions from the parameter reports or what shows in the log.

Maybe @tgauchat knows? As I said, it’s really hard for me to follow any specific code or log entry posts because I rely on text to speech.


(Nico) #7

The same thing happen with Aeon Labs multi sensor, the update interval is not like the value written on parameter.

I just got frustrated, how the interval is right when I set value 300 or lower and when I change to 360 or 720, the reporting interval is random. Not the exact value I set.

UPDATE :
The same problem with hex number.
When I set to 0x0010 , the interval time is 32 second. The log show update every 32 second
When I set to 0x01f4 , Which is 500 second. The interval time get random again.

This is 0x0010 parameter log

MeterReport(deltaTime: 32, meterType: 1, meterValue:
[0, 0, 9, 252], precision: 3, previousMeterValue: [0, 0, 9, 252],
rateType: 1, reserved02: false, scale: 0, scaledMeterValue: 2.556,
scaledPreviousMeterValue: 2.556, size: 4)

This is 0x01f4 parameter log

12:47:01 AM: MeterReport(deltaTime: 107, meterType: 1, meterValue:
[0, 0, 9, 253], precision: 3, previousMeterValue: [0, 0, 9, 253],
rateType: 1, reserved02: false, scale: 0, scaledMeterValue: 2.557,
scaledPreviousMeterValue: 2.557, size: 4)

12:45:15 AM: MeterReport(deltaTime: 393, meterType: 1, meterValue:
[0, 0, 9, 253], precision: 3, previousMeterValue: [0, 0, 9, 252],
rateType: 1, reserved02: false, scale: 0, scaledMeterValue: 2.557,
scaledPreviousMeterValue: 2.556, size: 4)


(Kris Schaller) #8

Hey @nico89s,

I’m trying to reproduce this, but am running into some errors right now with live logging. I’ll continue to try throughout the week.

I’m not 100% sure, but if I had to guess I would say that the max for this is 5 minutes. I’ll confirm this and get back to you.


(Nico) #9

Thanks @kris

I hope it’s not. The max value from aeon lab is 65535 and default value is 720 second.
ST able to send config parameter, but I wonder why it’s not working properly if we send more than 300 second.

reporting every 5 minutes is annoying, my smartthings activity is filled by energy reporting