ADT Hub System Test Required/Duplicate Sensors/Cellular Module Failure (July 2019)

It gave me the promotional trial again. The app said 7 days, the website said 30 days. Im not sure which one is correct but I will probably call ADT and get a refund from my old account.

Good to know, thanks! I might try this if I gain the patience to try again.

ADT reps on the phone will direct you to email for a refund request. An email address they provided at the domain adtcanopy.com bounces and doesn’t work anymore. Request they provide a billing contact at adt.com. Specify “SmartThings Billing” in the subject line.

I have yet to receive a response via email.

1 Like

Just wanted to chime in and say I’m having the same issue. I’ve had the panel for quite a while, and have essentially been self-monitoring it, but only activated ADT monitoring in June of this year. Unfortunately I prepaid for six months of monitoring.

This weekend I was trying to wall mount my panel, which was setting off the tamper alert, so I went into the “manage account” section of the app to turn on testing mode so that I wouldn’t trigger any responses from the monitoring center. To my surprise, it listed that I have zero monitored devices! On the SmartThings side of the app it still showed all my sensors under “ADT Monitored Devices”.

The first thing I tried was deleting and re-adding a motion sensor, which got me into the state where a system test is required, but running the system test immediately fails like it does for others. I called the 1-800-ADT-ASAP number tonight and talked to several people, only to ultimately be told that there is a service outage preventing the test from running and there is no ETA to fix it. They gave me the invalid billing@adtcanopy.com address to request a refund, and my email bounced. Talk about a frustrating experience. So not only does my system not currently have any monitoring, I only discovered that fact by accident and I have no idea when it stopped working.

If I can get a refund I may try the brand new account route suggested by @LTG. Otherwise I am incredibly frustrated with this system and my scrap it altogether and go another route, in spite of the investment I’ve already made in sensors.

1 Like

I am waiting a little longer to see if they have a fix. I don’t want to go through getting a refund of my prepaid monitoring and then pay for it all over again. Not sure if I want to commit to a longer period of time at this point.

I’m will try this if you have the same hardware version as me. What firmware version do you have? Mine is firmware version N.1.0 build 3908. Radio Modem 17.01.573.

What is interesting to me is the ADT canopy website can see the status of my sensors (open or closed) so how can they see that info if they “aren’t getting any signals from the panel”!

Yes I have the same.


Im not sure what is causing the issue. I think adt can see the sensors but not the panel. I think the account is somehow tied to some serial number in the panel. On my old account I could see the the test page being redirected to “https://mod.adtcanopyportal.com/customer#/premises/(some serial number)/start” and it would come back as page not found, just like the billing page.

You’re a genius! System test is working now but I have a bunch of extra devices. I had to make an entirely new account. I’m just glad that there is a path forward to get it to work again. Time to delete everything and add everything in again.

Let me know if you make any progress on getting a refund.

I emailed adtbill@adt.com yesterday. I have yet to receive any response via email.

I called ADT today to ask for a refund but I was left frustrated. A very upset rep in the cancellations department insisted I do not have an account and my Canopy account number starting with CPY is not valid.

I tried to explain this is a Canopy system and how I am an active customer, but she insisted “I have been doing this a long time” and needed to be transferred somewhere else. She transferred me to “the correct department” which meant putting me over to Samsung SmartThings support :roll_eyes:

Back when my ADT service worked I enjoyed it, but it’s really hard to get someone who can help with billing! The tech support rep I talked to yesterday from ADT said “we won’t be jerks about [a refund]” and said I’ll get a refund if I email them, but he gave me the broken billing@adtcanopy.com address.

Good luck everyone.

1 Like

I deleted my control unit, added it back and it is working fine. Now I just have to deal with the billing issues.

@reidburke I had the same experience, ADT was transferring me to Smartthings support any time I called them for help with the issue that was going on. Smartthings support would transfer me back to ADT.

How did you delete the control unit?

My control unit does not have a gear icon to delete it like my sensors do.

I found a very DIY solution which will work for folks who are web developers.

I deleted the duplicate control unit by deleting a sensor on adtcanopyportal.com while my browser’s inspector window was open. I then replaced the device ID in the sensor deletion request URL with the device ID of my duplicate control unit. I was very careful to use the correct device ID which I found by inspecting the JSON response of the Test Mode final step — one of the control units had a status of WAITING_RECEIVE (bad) instead of WAITING_VERIFICATION (good).

I was then able to complete Test Mode with all of my sensors.

I noticed my panel firmware version is now N.1.0 build 3908. ADT Monitoring Service says “Not Active”. The radio status screen shows a connected status.

I called ADT to verify connection and they told me they are receiving alarm signals. I asked not to be transferred to the Canopy department but for the frontline rep to verify instead. ADT has been referring me to the Canopy department at 855-622-8941 when I call about technical things. When I called this number, it did not work nor does the “internal extension” ADT uses. I asked the front-line rep to stay on the phone while they transfer me. This evening I was told this number works Mon-Fri 8am-9pm ET and weekends 8am-7pm ET and they are closed for the evening.

They told me there is an ongoing Canopy problem and my address shows limited connectivity in the system. Perhaps I will test again with Wi-Fi offline next week to determine if the cell backup is still working.

Good luck folks!

1 Like

Just logged in and all my devices are now back to showing correctly on the Canopy site.

2 Likes

Exact same issue. Hoping they fix it soon.

I was able to fix mine as well by deleting the bad panel. The steps I used: USE AT YOUR OWN RISK AS IF YOU MAKE A MISTAKE, I AM ASSUMING YOU WILL BE DEAD IN THE WATER

  1. open the adt portal: https://www.adtcanopyportal.com/login in chrome
  2. Login
  3. Open the chrome developers tools (f12)
  4. Click the network tab in the chrome developer tools
  5. Click the XHR button in the chrome developer tools
  6. On the ADT Page, click the begin test and continue until it fails.
  7. On the developer tools, you will see one is red. It lists bad controller id - Also in the request right before the red one, it lists all of your devices. You can expand those and ensure that the red id that failed matches the controller that was added most recently. Make sure you copy the ID field from the newest controller listed.
  8. Go back to the main menu in the ADT portal by selecting monitoring on the menu
  9. Click on your location
  10. Clock the gear on one of your monitored devices and select remove device.
  11. This takes you to a confirm screen. This is a good time to clear the google developer console so that you can focus on just the next request and response. One the developer tools, click the icon that is a circle with a slash through it, that will clear everything.
  12. Click remove device.
  13. Right click on the XHR request that was just sent and select copy and on the sub-menu of copy, select copy as fetch
  14. Paste that in notepad or similar and look for a line that looks like this : https://mod.adtcanopyportal.com/api/devices/a8c021b8-0857-408e-85b0-179fwfwe526d
  15. The part after devices above is the device id. I just made one up here, yours will be different
  16. Change that device id to the one that is the bad controller
  17. Copy the full fetch command after you made the edit
  18. Click console in the google developer tools
  19. Paste the fetch command in full
  20. Press enter

Your bad controller is gone and the requirement to test went away for me. After that, I added back the device I deleted to get the XHR request to copy.

Your mileage may vary and I take no responsibility if you try this and blow things up. It is on you! =) Cheers

4 Likes

Thanks for this!!

Mine was not failing any of the tests but was getting stuck on the last screen of confirming communication with home office or something like that. I looked at the XHR and copied the response it kept sending over and over and it listed all my device ID’s including the fake controller. I could tell it was the bad one as it had the added date. My original one was added a year+ ago and the new one showed a few days ago so I knew it was the culprit. I snagged its device ID and deleted my keyfob to get the delete code, swapped device ID’s and sure enough it worked like a charm. I added the keyfob back and everything is working as it should now.

1 Like

My system started working again. Based on my activity logs, my sensors started showing events on the adtcanopy site around 1:30pm yesterday. And when I go to the billing tab, it now works and shows my plan.

However… I still can’t complete a system test. All of the steps are successful until the last one, “confirming connection to monitoring center”. It gets stuck on that step and never completes. I don’t have any duplicate devices, and I only have one control unit, so I’m reluctant to delete it.

I got it working! I realized that I had somehow wound up with a duplicate motion sensor, which was the one device that I had deleted and re-added while trying to get things working in the first place. So I deleted it in the app, deleted the extra occurrence in the web portal, re-added it, and the test completed.

1 Like

@mrfleck — You just saved me
This worked flawlessly and am in your debt – ADT/ST couldn’t figure anything out

Samsung and/or ADT should hire you.

Thank you for the quick fix. Now to call ADT to see if I can uncancel my plan…

Jason