Issue with ADT Hub System Test

I have installed the ADT hub and window and door sensors throughout my house. There are quite a number of them. The last step to be able to activate the ADT monitoring service is to perform a system test. This is proving to be difficult. While doing the test, my sensors are getting picked up, but for some reason, there are duplicate sensors showing up in the list. One of them is checked and the second one isn’t.

So, for example, I will see two listings for my front door sensor. When I open the door, one of them gets checked but the other one doesn’t. This is happening for multiple sensors throughout my house, which means I can never finish the system test.

Has anyone experienced this and found a resolution? I have also done the test from the hub itself and it finds all the sensors as expected, but to be able to get past the system test, it also has to be done in the app.


This post might help with the duplicates (he had two keyfobs). You should be able to see the duplicate device, and remove it from the adt side following the instructions in this post.

1 Like

This is great. I’ve logged into the console and I am seeing the duplicates. I’ll try deleting them and retest to see if that resolves the issue and post back here with my findings.

Thanks @Mdterps!

So, I was able to remove the duplicates, but I still can’t complete the system test. While walking through my house and viewing the Smartthings app, I open and close each window/door. Some of them check off and others don’t. No rhyme or reason to it. Some will even check off and then uncheck again after a few minutes. Also, not all of my devices display in the list for the test.

I have tried multiple times and have called Smartthings support a few times. It has been escalated and waiting for the escalation group to call me back.

The saga continues. I’ve talk to several smart things support staff and have stumped them all. At this point, it has been sent to level two support but that was over a week ago and I have not heard from them yet.

I’m hoping this hasn’t turned out to be a big waste of money and time, but it is starting to look that way. I’ll post back if I ever get a resolution.

I ran into a similar issue when I was setting up my system and account with ADT. I had 6 phantom sensors. Going to the Canopy portal worked for me though. One thing I found is that you can delete the real sensor leaving the phantom one behind causing all sorts of mischief. If you are very deliberate and make sure you are truly deleting the phantom sensor it will work. Hope you were able to get it to work out.

If this issue is still ongoing, I recommend you open a ticket to SmartThings Developer Support so this issue can be reported and fixed or escalated to the proper team.