Added user but forced to log in with my account

accountsharing

(Sailesh) #1

Have SmartThings Hub v2. Set up hub and have successfully added my devices as well as my Android phone as presence sensor.

Wanted to add my wife’s iPhone as a presence sensor. Followed instructions to add her as a user to my account. She registered for a Smartthings account and looks like a Samsung account.

However when she starts up the Smarthings app on her iphone and selects I’m a SmartThings User and enter’s her email address she is taken to the website us.account.samsung.com and it asks her to use my account instead of her own. Can only Accept or Cancel. Clicking on Cancel just takes her back to the SmartThings app and she starts over again (selects I’m a SmartThings user).

We also tried to Accept using my Samsung account and she can access the hub and devices BUT can’t add her phone as a presence sensor.

Is this how it’s supposed to be? Can she not log into the hub with her own account and not use my account?


(Jason) #2

I had the same issue, any new account created is a Samsung account and it will not let me access smartthings. When it does login it logins as samsung and there are no devices associated with the account. Interested if other people are having this issue.


(jkp) #3

Try clearing your mobile browser cache to see if that resolves the issue


(Sailesh) #4

So far I’ve tried the following

  • deleting the user and reinviting
  • Deleted app
  • reboot iPhone
  • removed hub / location from my account and started over

Every time I add my wife as a user and she logs into her SmartThings account it forces her to use my Samsung account instead of hers.

Will try clearing cache to see if that helps


(Dan) #5

Since her account is a new account, she should not select that she’s a SmartThings User. Those are the older, non-Samsung accounts. Have her select that she is a Samsung User instead, if that option is given.