Add Kasa Devices Not Working (18 Feb 2024)

When trying to add a device I get this error message: “Something went wrong. Try again later.” I have tried several times over several days.

1 Like

I’m sure that’s very frustrating. :rage:

What’s the brand and model number of the device?

Kasa TPL Link, Models HS200 and HS210

Those are Wi-Fi devices and are supported by the ST to Kasa/TP-Link cloud->cloud integration. You must first add them to the Kasa/TP-Link app then link your ST account to your Kasa/TP-Link account in the ST app.

2 Likes

I completely understand. We already have many Kasa and Ecobee devices linked to ST. We have a significant installation with several tablets in various rooms.

Are you trying to add these using the linked service or the TP-Link Kasa Edge Driver (also LIFX)?

Sorry Terri, weve been using Kasa switches, plugs, outlets and motion switches for a couple fo years, but i have no idea what you mean by [TP-Link Kasa Edge Driver (also LIFX). We simply install the Kasa devices, set them up in the Kasa app, the normally simply + Add Device in ST. Recently, we encountered the error message “Something wentg wrong. Try again later.” This has been happening for over a week with many attempts.

try Menu > Settings > Linked services > TP-Link | Kasa Smart - first check that it does not show disconnected. if not disconnected, tap on it and tap on Refresh. If you are still unable to discover the new devices, you may want to consider Unlinking and adding Kasa back (but note of caution - would you still get the error? :man_shrugging: :man_shrugging:)

Jkp, thanks for the advice to unlink and then relink. As I mentioned, this is not a new problem. I can do an unlink and relink, I tried that in the past. All scenes, automations and widgets in SmartThings become unlinked and need to be rebuilt. We have over 100 devices on this account.

As an aside, al device are visible and actionable in Google Home which means this is a SmartThings issue.

contact both ST and Kasa support. Kasa maintains the integration so it is always possible it is on their end. I imagine each will say the issue is with the other party though.

3 Likes

Ain’t that the truth, we expect counter finger pointing.

Most important, out of the thousands of users of SmartThings and Kasa, are we the only ones experiencing this problem? If we are the only ones, maybe we have to look inward. If it is a common issue, then Kasa or SmartThings should have a solution.

1 Like

I am now facing the issue. I unlinked them to try to relink and can no longer get it to link it. Stuck in a loop.

Try selecting another browser as the default browser on your device. You can switch back after the attempt to relink Kasa, whether successful or not.

1 Like

You, my friend, are awesome. This ended up solving the issue. Thank you so much!