TP-Link connection issues

I have multiple Kasa tp-link devices which were running fine in my smartapps. I was using
name: “TP-Link (unofficial) Connect”, namespace: “beta” from 2017 I believe. It had “Beta” in the name.

My devices are HS100’s, HS 105’s. I’m on a v2 hub using classic app.

I added the new handler: TP Link Plugs and Switches Device Handler, 2019 Version 4 and the new manager (TP-Link SmartThings Manager and TP-Link Cloud Connect, 2018 Version 4). But now I have troubles. All my plugs show OFFLINE. I can control the plugs from the Kasa app with no issues. I try to add a device (plug) with the new manager. I select the device and click Save. All that happens is there is a spinning icon under the Save button (ST app). It never exists and if I go back in to select another device (plug), no device has been added.

I thought maybe the device is not in remote control. However, I can’t for the life of me find the “remote control” slider in the Kasa app (ver 2.11.0).

I removed all my tp-link devices from ST devices and deleted the old beta manager. It didn’t help.

Basically, I can’t get the new manager to add the tp-link devices. Any ideas?

First, open logging. Go to application. Select to update your Kasa Token and update. This will have several effects

a. May fix problem.
b. Will provide log information to paste here with error you are actually getting.

Second, open app again and go to add devices. (You should have none to add). Added effect:
c. Will force update of the IP address incase this is out of sync.

Lastly, uninstall all and install again reading the instructions carefully. You are going from a relatively old version to a new 'improved’ version. A lot of data changes to improve the integration - but I could not make it backward compatible with the old installation. (I always say on update recommendations: “if it ain’t broke, don’t fix it”.)

Added. Also try saving preferences on the device. Do this first. It may update some variables that are causing the problem.

Thank you. Your code works perfect, my brain…another story. I made a mistake. Thanks again.

1 Like