500: Internal Server Error. How to fix it? (March 2019)

Hello to all,
i have already opened a ticket: #717153

If i try to login to the api website, and check the device menu, it shows to me:
Error
500: Internal Server Error
URI
/hub/show/83b197ad-f6f4-45d5-a8fd-e1f8317acbf3
Reference Id
a4d9a839-eda9-492f-8dad-564a47768c7d
Date
Fri Mar 29 20:56:02 UTC 2019

What i tried to do:

  • create a new location, set it as default, and tried to delete the “old” locations. But it doesn’t work, the location has not been deleted and there still the server error
  • factory reset of the hub, then tried to add it to the new location using the smartphone app. The app can see the hub, but the process end with an error “unable to register the hub”.
    After it, the hub reboot automatically, and at the end it’s still connected to the “old” location, but i still have the server500 error for it.

What can i do?
cheers

Try logging into IDE using an incognito/private tab in your browser

2 Likes

Thanks, already tried but same issue.

You should be good now. One of your device records was corrupt and had to be deleted, Xiaomi Aqara Temp Sensor.

2 Likes

What a quick help :slight_smile: Thank you very much, yep i checked and it works. I will try to connect again the sensors, hoping to not have to contact you again for the same issue eheh

1 Like

I have the same problem. Need to get some Aqara Button devices deleted. Also have an ticket: #717185

I had 2 temperature sensors and it worked fine for a while. Yesterday i connected a new one, and tried to connected the door/windows sensor too without success. After a few hours i had that problem.
After you deleted them, did you manage to connect them again with no issue?

thanks

Same problem. Loaded the “Universal Enhanced Z-Wave Lock” DTH from RBoy, assigned it to a lock and now I’m stuck with the error. Help ticket is 19040201128.

Thanks,
Dan

Same here with a zxt120 AC infrared with ticket 719649. The device list, the hub and the location show internal server error.

Thank you.

Smarthing support removed the device in fault today. I added them back in and all of them are working as expected.

Four days just to get a corrupt device removed? That’s not good.

I ma having the same problem. How do I issue a ticket?

@glarrydn go to the support site and send an email. It will return a ticket number to the email address you used.

A change was deployed today to alleviate this issue. Let me or support know if you have further issues but I have not encountered the issue from any users that previously reported it.

1 Like

maby u can help me with this ?
i cant create device handler

Error

500: Internal Server Error

URI

/ide/device/create

Reference Id

14896b3b-f064-4f2f-8e26-c5a284932fae

Date

Fri Jul 05 22:16:36 UTC 2019

this seems to be a common problem. Try using an incognito/private browsing window.

Hello,

I am getting this error when trying to create a new device.

Error

500: Internal Server Error

URI

/device/create

tried different browsers/incognito mode etc - nothing works :frowning:

IS there anything I can do to fix this?

1 Like

Same here. Can’t edit devices, add devices or smartappas. Support could you fix it?

EDIT. ticket number: #794629

1 Like

Same Probleme here

Same problem,

When I create a new device or edit an existing device I get an error 500, for example

Error: 500: Internal Server Error
URI: /device/create
Reference Id: 3c6401f3-5d96-4b90-a43c-d4154a0f149c
Date: Sat Sep 14 16:51:13 UTC 2019

Also tried different browsers and incognito mode. It looks like it happens after the latest firmware update.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.