3 gang switch - Zigbee

I bought on Aliexpress a 2 way and 3 way Zigbee switch. It did not worked out of the box, but after changing Device Type to Zigbee Multi Switch it worked for the 2 way switch. Two devices appeared (Parent and child). The child device type is Child Switch health. It works just fine.

When I connect the 3-way switch, the SmartThings and do the same things - only 2 of 3 switches appear in the app. The network device of the parent device is: BB6B.
The network device ID of the Child Switch is : BB6B:02.

ANd it works for two push buttons. When I change the network device ID to BB6B:03 - the app controls the 3rd button instead of the second button.

I cannot add another child device and connect it to the parent device and make these two devices IDs : BB6B:02 and BB6B:03.

Any ideas how to do this?
Maybe a custom device handler is needed?

The switch is on Tuya chipset.

Hi. Don’t know how it happened, but suddenly the third button appeared in the devices list.

I changed the ID to :03 and it works now:

looks like all works fine - the switch is good quality and works great. Good buy.

Glad it worked out!

Just to avoid any future confusion, that’s a “2 gang“ and a “3 gang” switch, not a “3 way” switch, which would be the accessory to a master switch so that the two switches control the same light fixture.

Thanks! I’m not native english, good to know the difference!

1 Like

Can you include a link to these on Aliexpress? I’m investigating what options I have for these switches at the moment.

Of course

dzięki! :slight_smile:

Unfortunately the problem is back.
I bought another 3 gang switch (the same type) and I can’t set it up. Below are both switches side by side. We can see that the one on the left has two child devices, and the one on the left has only one child device.

Any idea how to change it ?

What I noticed is that the child devices have the same device ID. but with numbers at the end:

I tried to add the device manualy but, it didn’t work. The device was not visible as child device in the Parent device.

This is the 3 gang switch that works fine:

Any idea how to set this thing up ?

Maybe try to add (or delete and add) the device again. It is an issue time to time, that child devices are not spawning as it would be required.

I managed to set it up. I changed the deveice handler to another handler that has 3 buttons. System recognized 3 things (never mind what type they are - it is only the matter of adding them to the hub, they do not need to work properly) System recognized 3 things, one is parent and two are child devices. . Once they are on the list I changed them to Zigbee Multi Switch.

Stupid, but works :slight_smile:


Could you let us know what dh did you finally use?

Yeah sure.
Zigbee Multi Switch is the main switch, and the 2 other gangs are Child Switch Health.

Do u know any good 2-way switch ZigBee or zwave.

I really couldn’t find anything except for neo coolcam and it exploded as soon as I connected it lol

This is wifi or ZigBee I couldn’t find a ZigBee version or am I missing something?

Hi, I have the same issue. Which handler did you use to get it to recognise 3 switches? You said you use a random 3 channel device, I can’t seem to find one.

1 Like

Just thought I would let everyone know how I got this to work.

When smartthings detected my 3 gang it showed as a Thing.
I then selected this in the devices and changed the type to IOT8-Z and selected update which then changed the device to have 8 child switches.

Next edit the parent device and change the type back to Zigbee Multi Switch.
This keeps the 8 child switches.

The type will be wrong on the child devices, so you need to select the type Child Switch for the gangs that are on your switch ( Mine was three gang ).

The names and labels should now be changed to something more meaningful and delete the child devices that are not used.

My switches are just Generic Zigbee smart switches purchased from ozsmartthings.com.au
Here is the device 3 Gang Zigbee Smart Switch

The main issue that people run into is that multi gang switches produced by Tuya (and sold under many different brand names) use a proprietary command structure that doesn’t work with a true generic DTH. (Search the forum for EF00 cluster and you’ll find several discussions on the issue.) So just knowing a switch is zigbee 3.0 isn’t enough to know which DTH will work: you need to know if it’s Tuya-made or not. :thinking:

1 Like