2 gangs of 3 Gang Power Switch stopped working after ST Upgrade

I have a 2 gang and a 3 gang power switch. Only one of the gangs work within ST.
I tried to remove the 2 gang and readd it - only one switch was added to ST, no child switch.
I did not remove the 3 gang - for this the status is that I see one ZIGBEE and 2 EDGE_CHILD switches in ST App, the “ZIGBEE” works, the others are CONNECTED but have no function.

I appreciate any help

brand/model of the switches?

I had very similar situation that I solved with these drivers…

Default Clusters
Personal Tuya Devices

They both worked in my case.
They treat this situation differently.

Thanks for your fast response and sorry for my late.
I installed the driver but cannot swtich the device to the driver - get error message

Error changing device driver to “Zigbee Smart Plug with child devices”. Ensure that the driver you are trying to change to has a valid fingerprint match with this device.

any idea?

Hi - thx for your fast response and sorry for my late
I do not know the brand and model. Was a cheap switch within amazon - no longer available.
I assume it to be a tuya based brand - zigbee.

The same ones with single gang work without problems. only the 2nd and 3rd gang is in error.
Maybe I should try a tuya zigbe bridge and connect via tuya?


It seems you haven’t tried both.

Personal Tuya Devices also acts like “Zigbee Thing” so we can get some informations to understand what is happening.

I haven’t tried both cause I have no tuya zigbee hub to try.
The main gang (SW WOZI ESSEN) uses driver “zigbee switch” and works. The childs don’t have own drivers and do not work. They are shown as type “EDGE_CHILD” without functionality.
In the app they appear as connected only - no switch symbol - no function.
If I switch the driver to “Zigbee Thing” the main gang also stops working.


tuya zigbee hub would be necessary for cloud integration.
zigbee drivers are for local integrations.
in other words, you don’t need tuya zigbee hub to use any zigbee driver.

if the driver “zigbee switch” created the main AND child devices and isn’t working properly, then it is faulty or isn’t proper for your device.

the idea is to pair the device again and let any of these drivers to recognize the device.

child devices are dependent of main device.
you can’t have a driver for the main and other driver for a child.

most drivers that pair “Zigbee Thing” are meant only for exposing technical informations used to be added to another driver.
in other words, they won’t make your device usable.
we first need the technical informations to help you identify the proper driver to your device.

Now I understand.
I did the repai of the switches in the past but I did not repair them after installing the new drivers.
Now I again deleted the devices and run the pairing - they work :rofl: :rofl:

Thank you very very much for the driver and your help.