3 Bosch Motion Sensor (ISW-ZPR1-WP13): Smartthings V2_Hub all stopped working last night

I have had three Bosch Motion Sensor (ISW-ZPR1-WP13) working fine with the SmartThings Hub for the last 3 years with the only issue a occasional battery change; however, Last night 7/22/2023 all three of them stopped working but all the other sensors and switches continue to work fine. In researching the issue today I found out the Groovy interface is gone and SmartThing has switched to Edge. Because the was custom drivers for the Bosch Motion Sensor that are no longer active would explain the problem.
I removed a device and tried to reconnect it and it would not pair. I power cycled the Hub byt rem9oving batteries and removing power. After the recovery i was able to connect the device and the other two devices connected as well using the Zigbee Thing driver. all three just show as connected but have nor other information like battery and temperature and don’t report motion detected.
I tried to change the driver to Zigbee Motion detector on the new device summary page but it said there was not finger print for the device and reset to the base Zigbee driver.

SO the best I can tell is the finger print needs to be added to the Zigbee Motion detector or a new driver created.

Does anyone know if there is anyone working on this or what the status is on a new driver?

2 Likes
1 Like

Same boat here, did same troubleshooting, no luck.

Question - the Bosch PIR motion detector is a ZigBee device. Did the fingerprint get updated on the Z-Wave edge device driver?

Zigbee and Z-wave device have totally seperate drivers.

Mariano driver listed above is for zigbee motion sensors.

1 Like

Both of my Bosch PIR motion detectors stopped responding on 7/20/2023 and the device type was changed to “Zigbee Thing”.

They are both working after obtaining the beta “Zigbee Motion Sensor Mc” driver from Mariano Colmenarejo on Github ( GitHub - Mariano-Github/Edge-Drivers-Beta: Edge Driver Beta Modified for Created ). After logging in to your SmartThings account, you can obtain an invitation for his shared channel at -
Samsung account
You can then enroll and install the “Zigbee Motion Sensor Mc” driver.

Changing the driver for the Bosch PIR Motion Sensors to “Zigbee Motion Sensor Mc” made them functional again ( Samsung account ).

5 Likes

Thanks for the detailed directions.

Mine also stopped working recently. The device type was changed to “Zigbee Thing”.

I followed your directions and changed the driver to the “Zigbee Motion Sensor Mc” but it seems to be not working properly. It’s not reporting motion or temperature even though it’s been about 30 minutes.

I had to remove it and add it again and now it’s working.

@wjwong Thank you these direction were perfect and fully resolved my issue. I had no idea how to get Edge drivers and this answer it. Thank

Can you post instructions on how to re-add it? I removed it, put in new batteries, and it started blinking in three pulses. Then went to smartthings, tried to add a Bosch motion sensor and it asks for me to put in the batteries. But it never connects…

This is the second item I have lost to these new edge drivers. I am getting really annoyed that my system is being overwritten.

Edit:
Ok, on closer inspection I think I got it to work. Everything is showing up but it’s a bit rough. Temp is off and real time motion detection isn’t happening. But it is working, I think.

So, I’m guessing smartthings is on the way out? This new system is going to wipe out a lot of older products. I bet people are not going to go out and buy all new devices and are definitely not going to trust smartthings to not completely wipe out their systems. I’ve spent many years building, adding and refining my iot system. Now I’m losing piece by piece. Ugh…

I had trouble re-adding mine but I finally got it to work.

The key, I think is the sequence of how you add batteries.

  1. Insert 2 batteries, 1 in each compartment first.
  2. Hold the sensor so the temper switch is at the bottom. Hold down the temper switch and insert right battery first then the left battery. Within 4 seconds, let go of the temper switch.

On Smartthings app, scan for nearby devices and it should pick up the Bosch sensor.

Make sure the driver is the new “Zigbee Motion Sensor Mc” one.

Close the back cover and it should be good to go.

Yes! Thank you. It worked well. Now if I can get my ancient zooz chime working correctly, I’d be thrilled. It seems zooz won’t support it any longer. Ugh…

One down, one to go.

Thank you very much!

Thank you everyone! My Bosch PIR sensors stopped working on July 20th and after authorizing Mariano’s drivers, I simply went to the device in my smartthings app and changed the driver and it worked in 5 seconds and seems to respond instantly! Yay!

2 Likes

Thank you! Worked!!

It shouldn’t do. The most recent spate of issues seems to be mostly caused by users having installed custom device handlers for their devices years ago because they weren’t supported by the SmartThings managed ones. Unfortunately they didn’t appreciate that they had joined in a game that played on with or without them. They needed to have repeated the process for Edge drivers but they hadn’t. So SmartThings did the best it could with what it had available. More often than not a new solution was again ready and waiting in the community.

I think it would be fair to say that SmartThings could be a lot better at effective handling of generic fingerprints. It wasn’t unusual for custom handlers to just be used to allow the devices to be recognised, the rest of the functionality in the handlers was often no different to the stock handlers. The same thing seems to be pretty much happening again with custom Edge drivers. It is a concern.

1 Like

Thank you! After installing the Edge Driver, I had to re-add the device to make it work.

Hi. I decided to again try to get my Bosch motion detector working and reading this thread. I went to where I thought I last edited the driver Samsung account but there are no devices there. Is there a different URL I should be using? Also I’d appreciate basic instructions on how to add the new driver, its been a while since I’ve done this, the github site with the driver doesn’t have much info. Thanks!

After deleting an re-pairing it worked! Thanks to Mariano and yourself

1 Like