Bosch Motion Sensor (ISW-ZPR1-WP13) : Smartthings v2 hub

Has anyone got the Bosch Motion Sensor(ISW-ZPR1-WP13) to work with the Samsung Smarthings v2 hub. I had bought this sensor at mydigitaldiscounts in a recent sale.

I have tried using both the following Device Handlers, removed the batteries and set in detection mode, but samsung v2 hub just does not detect them inspite of multiple attempts. I click “Add a thing” and it does not detect these devices, even though the red light keeps blinking in pairing mode.

  1. https://raw.githubusercontent.com/tomasaxerot/SmartThings/master/devicetypes/tomasaxerot/bosch-motion-detector.src/bosch-motion-detector.groovy
    2.https://raw.githubusercontent.com/smcasagrande/SteveC_SmartThings/master/devicetypes/smcasagrande/bosch-motion-sensor.src/bosch-motion-sensor.groovy


Maybe a hub reset will help.

1 Like

I have three of these devices and they work fine … things to keep in mind - it only sets motion for the first 4 seconds and then will not hit again for three minutes

ie: I walk by the sensor it trips to motion 4 seconds I come back 60 sec later it will NOT trigger

I use these with webcore for hallway lighting and have it setup so that on motion it turns the lights on for 3.5minutes this way if it retriggers after 3m the lights stay on. For this type of use case they are perfect (cheap, reliable, long battery life, etc) but for others they just wont work right due to the timouts

2 Likes

Try bringing the sensor right near the hub, within three feet of it or so. That way the pairing is direct, rather than trying to happen via the z-wave mesh. Once it’s paired, install it where it will be used.

Just did a hub reset plugging out the wires at the back of the hub and reconnected. Repeated process of removing batteries and clicking on the pairing mode switch on the back of the Bosch sensors. The red lights are blinking fine repeatedly, but the “Add a thing” does not detect them for more after more than 5 minutes. The sensors are placed on top of the hub while trying to reconnect. I think I am simply draining the batteries.

Have both the device handlers (SteveC and Tomasaxerot) saved and published for me in the “My Device Handlers” simultaneously. Have also tried these individual device handlers separately, but “Add a thing” does not seem to detect them even though the red lights are blinking constantly. The sensors are placed on the hub, while pressing the switches at the back for reconnect, so I dont think distance is the problem.

Did not face any problems with connecting multiple samsung multipurpose sensors and Arlo Q camera though.

So they never connected? Did you put the switch on the bottom in the lock position after re-inserting the batteries? Should still be able to pair in the unlocked position I think.

The instructions state to also put the cover back on the unit after doing this. these are tricky to pair although my first time was like 10 seconds without looking at the instructions. Not so quick the 2nd time.

Did you figure out a way to decrease the interval?

There is no way to do it, it is in the Firmware and unconfigurable.

Thanks for replying back. I saw your comments about using WebCoRe in some other thread. Thanks for that as well. Its really nice that I can customize the automation and see the logs.

1 Like

Glad to help! Honestly the sensors are great - as long as you can work around the limitation of the 3m sleep window

Hey John, how did you managed turning off the lights after ‘no motion’ is detected after an specific time since this sensor triggers the no motion event about 4 seconds later? Within WebCore I mean. Thanks

It’ll be great if you could share the piston to created for it. Thanks again

As I moved everything over to Hubitat, I went and created this quick in the Hubitat webcore I am running - not sure if you can import this one, or if you will need to create it by hand … but here we go :slight_smile:

If you create by hand - the important parts are 210 seconds I find to be the ‘sweet spot’ and you need to set the Task Cancelation Policy to NEVER cancel tasks…

To do this by hand - click on the “WITH” statement, then the gear on the dialog box to open the advanced options… then in Task Cancellation drop down, select Never Cancel Tasks

This will keep the light on for 210 seconds from the last motion detected, so timeline:

Second 0 - Motion Detected
Light on
Second 211 Light off

Or… continued motion

Second 0 - Motion Detected
Second 93 - Motion Detected - RESTART COUNTER

211 seconds after last motion Lights Off

Let me know if that works/helps

1 Like

I purchased 2 of these motion sensors from mydigitaldiscount.com. On the product description page, there are SmartThings integration instructions AND a link to a DH that works just fine with the sensors I purchased. Here is a link to the page:

https://www.mydigitaldiscount.com/bosch-security-motion-sensor-pir-pet-immune-for-samsung-smartthings-and-other-smart-hubs-with-zigbee-wireless/

I hope this helps.

For the record, these are Zigbee sensors. They have their own system for exclusion. I got them used on Amazon and figured they’d need a reset in order to pair. I was right. The instructions are detailed, but if you don’t have them and are having trouble pairing, do the reset sequence:

  1. remove the top two batteries
  2. press and hold the tamper switch between them
  3. Reinsert the right battery, then the left.
  4. let go of the tamper switch
  5. put backing on the sensor

Do this as you have “Add a thing” active and it’ll likely pop up. If not, do the reset sequence again.

Continuing the discussion from Bosch Motion Sensor (ISW-ZPR1-WP13) : Smartthings v2 hub:

How to fix your issues with the Bosch ISW-ZPR1-WP13 motion detector.
This explanation is in great detail and very long. It will make your detectors work and if they don’t you will now know why.

I’m not wanting credit for this because I’m a newbie in this whole thing. The only thing I did was to figure out a sequence of events that other people did though in this combination it just works. All of my testing has been done from two Android devices and on Windows 7 PC for accessing Smartthings IDE (there online developer app). You must have a Smartthings account, not a Samsung account. You can have both, but only use your Smartthings account for your Hub. If you can’t, it’s because you don’t have a V1 or V2 Hub.

If you don’t know the difference between the two accounts then use the correct URL below to access it:

Correct: https://account.smartthings.com/login/smartthings

WRONG: https://account.smartthings.com/login/samsungaccount

  1. Please, everyone state what type of Smartthings controller you have. This is super important. First off do not even attempt this with the new Samsung Connect Home Mesh Wifi Smarthings Hub. It requires the Smartthings (Samsung Connect) app. You will sacrafice a weekend in the process and I never made it work at all. Most of you that say it discovered a “Thing” are using one of the new Wifi contollers with a Hub built in that you enable. For now, I recommend not using them. I hope as you do that Samsung will bring back the functionality of the original Hubs someday for them.

  2. You want things to work correctly use a Smarthings Hub V2. I can’t make comments about V1.

  3. Use Smartthings Classic, Not Smarthings (Samsung Connect). And once again use a Smarthings account, not as Samsung account.

  4. Do not run the V2 Hub along with or in conjunction with a Connect Home wireless router unless you disable the Smartthings hub within the router. What a joke, but believe me if you do you will have issues, LATENCY and and severe connectivity issues with devices.

  5. I have found that some, not all, home wifi mesh systems just toast the whole process. For testing, use one wireless router and a cable to get your ST V2 Hub away from it a very good distance. Testing, testing, you know the drill.

On to the reason you are reading this. How to make the Bosch ISW-ZPR1-WP13 motion detector work correctly.

Here are the symptoms I encoutered in no particular order.
Could not add the device.
Could add the device but then it was stuck on Motion or no Motion and would not change though the temp and battery seemed to work.
Could see it, add it, and it worked while in Walk test mode, but 2 - 10 min. later it was gone until I power cycled it or sometimes just triggering the tamper button.
Sometimes they would work for a few hours.
The battery sequence to clear reset the device wouldn’t do anything. No flash, nothing.
Taking off the back and putting it back on (tapping the tamper button) would not put it into test mode.
I was going to throw away two out of the six detectors I bought, but then I figured this out.

Follow this exactly with no exceptions and hopefully you will be happy you bought these things because if you are like me you just wanted to smash them.

Sequence:

  1. Log into your Smarthings Account IDE (Integrated Development Environment) with a PC preferrably or a browser of some type, NOT YOUR SAMSUNG ACCOUNT.

  2. Select My Locations

  3. Click on the HUB/Location you are now working on.

  4. Go to My Devices at the top.

  5. Remove all of the Bosch devices we are discussing.
    Note: Very important. Do not use the same device names again. If you do, this will not work If you have one called “Front door motion” then do not use it again when you add the devices back in. Call it “Door Front Motion” or something. Later, after all your testing you can come back and change the name to what you used to have it. This is a MUST>

  6. Go to my Device Handlers:
    Make sure you have only one device handler for this type of device. I highly recommend you use tomasaxerot : Bosch Motion Detector (it’s available all over the place)
    Important note: There is a simple mod to his handler that I will tell you about later that makes this process more easy. I don’t know and I apologize if I’m doing something wrong telling you to make this change. But, if you follow the rest of this you don’t have to change his code at all and it still works perfectly fine.
    If you have another handler for this device, remove it. Now make sure you go through the correct steps in adding this device handler back in. Most of you know the steps. Go find the Device handler mentioned, hopefully you find the one that you can select Raw and then copy, then add new device handler. Do not type anything into the “From Template”, select From Code, paste in your copied code, select Create, then Save, then publish. Now you are ready to add your motion detectors with the following approach.

  7. Put in the bottom battery in both the left and right side. Now do not push the top batteries into place, just set them in with the negative side in place but the positive side is sticking up on both the left and the right side. Some ask what is the right side. While looking at the back of the sensor being the batteries, the tamper trigger is at the bottom. The right battery is on the right side of the sensor. Remember at this point neither of your top batteries are touching on the positive side, correct. Both are fully ready to snap in.

  8. You have less than 4 seconds from the time you push in the first battery to do this. If you fail, remove the top batteries, wait at least 20 seconds and try again. Here we go. Press and hold the tamper trigger, push down the battery on the right side until it snaps in place, now do the same on the left one. Release the tamper trigger. If you did it correctly it will typically blink a few times rapidly, and then after a bit it will start that 3 blink thing it does when it is in pairing mode.
    Important Note: You do not need to put the back on. Sometimes some don’t but they will still allow you to pair. If not, do the sequence over again but this time snap on the back, wait at least 30 seconds, open the back for a few seconds and then close it. It will probably go into Tamper mode and blink like crazy and that is a good sign. Just set it down and wait until it’s done on it’s own. It will then go into pairing mode.

  9. Now select + or + Add a thing. If your device doesn’t show up, go back to step 7 and do it again. If it does show up Select Rename Device. Give it some odd name you have never used. Then select Done and then Save. It should could back with Confirm Paired Device, select OK.

  10. Go back to Samsung IDE and look up your device. If not there, refresh the page, Click on the device. Scroll to the bottom and select Edit. Click on Type (drop down) and change it to “SmartSense Motion Sensor”. Then select Update at the bottom.

  11. Wait for 20 to 30 seconds or longer and then snap on the back. Do not turn the lock tab. At this point or in 10 seconds or so it should go into walk test mode. Some don’t and you have to open and close them a second time. Now it should work.

  12. Now you can go and change the Name to what ever you like.

This brought all my messed up sensors back to life and made them work correctly again. This does not fix the 3 or 4 min delay in between motion detection. Yes it’s probably a hardware setting but I feel it can be forced by the Hub to do what you want. Why? Because it makes no difference what stage of the game you are in, when you select remove a working device it contacts that device immediately.

Note: I hope as mentioned above that I’m not doing something wrong in telling you this. If I am I do honestly apologize and will modify my post if I am.

If you want to skip step 10 above then modify the device handler. Go to Line 20 where it says “Bosch Motion Detector” and change it to “SmartSense Motion Sensor”. It will notify you it has been modified, then save and publish. My tests show that it works. Not guaranteed but it appears to work.

If you change the order, sequence, add or subtract from this approach it doesn’t work. Follow it, ok?

Finally freedom using Bosch

4 Likes

Good day sir .
Can you share your create device handler thanks…

Not sure if this will help anyone:

I am using Smartthings hub v2
Samsung Account
Smarthings (Samsung Connect) NOT CLASSIC

To get mine to work, using the above environment, all I had to do was use Spec Techs info about changing the Device handler code:

“Go to Line 20 where it says “Bosch Motion Detector” and change it to “SmartSense Motion Sensor”. It will notify you it has been modified, then save and publish. My tests show that it works. Not guaranteed but it appears to work.”

I then re-added the motion sensor and it is working beautifully.

1 Like

Hey guys got one of these Bosch ISW-ZPR1-WP13 sensors about 7 months ago, had nothing but problems trying to get it to connect, since I was trying to install this on my mom’s smarthings v2 system I just lost track and due to previous frustrations just abandoned it for awhile. Well back at and after using the [tomasaxerot : Bosch Motion Detector] device handler when ever I try to pair the device it always shows up as Thing. No matter what if I edit the Thing change the device handler to use the Bosch Motion Sensor it never works, I even tried the Smart Sense Motion but nada. Not sure why this sensor is so difficult to get to show up correctly. Never had problems with all my other zigbee devices that had used custom device handlers.

Shows up under “Thing” as:
Data
application: 24
endpointId: 05
manufacturer: Bosch
model: ISW-ZPR1-WP13
Raw Description 05 0104 0402 00 07 0000 0003 0500 0020 0402 0001 0B05 01