2016 Samsung TVs no longer compatible?

Thank you for all the info and troubleshooting. I am trying to find out if there was a change impacting 2016/2017 TVs. I found a few old records for your TVs. They were using the non-Groovy “placeholder” device type. I am still not clear why you are having issues with them though.

Thanks Brad. If there’s anything else you need me to do, or any information I can give I’ll do my best to get it.

Look forward to hearing back.

1 Like

Mine is not in the new app list either Brad, UE65KU6020

if I ever need to reset i doubt it will get re included as its not in the new compatible list

And I have just noticed that switching inputs as a device option is also not available, or it is but limited to 2 inputs rather than the previous full list of inputs
Ie: hdmi1
Hdmi2
Hdmi3
Tv
Now I just see TV and 1 other hdmi input
Looks like the current associated controller in the app is not as full featured as previous in the same new app

Has anyone else noticed ON is now available if the TV is OFF

Even though the Tv shows not available and a banner appears over the whole device page saying check connections blah blah , if you hit OK to clear it, the on off button is now live and turns the Tv on ?? Or is it just me and some odd fluke

I still don’t have on as a device option in automations and echo does not switch on the TV

Controler version 2.CR04.0909

An update to this… The other (identical) TV now works perfectly with Android 11.

I still can’t add the one I removed.

Next update… I still have the smartview app which I used when the TV control was less granular in the classic app. Neither TV can be found in that app.

If I open YouTube, I can cast straight to either TV no problem.

Ok, so support finally came back…

Is that really true? All TVs more than a couple of years old are no longer ST compatible??

If this is true, I really have had the rug pulled out from under me. My other (identical) TV is now fine, but I don’t think I’ll be able to add it again if I ever remove it if this is true.

From a commercial perspective this is bonkers. After the withdrawl of all other apps, I can no longer control this TV with my phone. I have an LG TV elsewhere in the house which is considerably older, and the app still works with it. If I have to replace my Samsung TVs every couple of years to be ST compatible, then there is little point in buying a Samsung TV in the future!

This really seems misguided (if true). I can’t imagine having to regularly replace ‘things’ as they get old, just because Samsung thinks I should. Clearly the TV would still work if it was actually listed, as I have an identical one which is now doing just that!

Commercially a bad move in my humble opinion.

@Brad_ST - can you confirm this either way?

This is extremely disappointing. I have 2 2016 Samsung TVs, and I will not be replacing them for several more years. TVs are not something people typically replace frequently, so this is a super sucky move on Samsung’s part.

I think this isn’t correct… I had a second empty location with only a 2016 Samsung TV in yesterday which was fully working in the current app. Due to the migration I deleted the old location and the TV from that location , but it won’t add now to the location all other devices are in.

This works fine, there is some kind of pairing/device add issue that Samsung needs to resolve. The functionality does work…

Disappointing response there I agree.

After re-adding the tv to ST, it shows as directly connected and will not allow me to add to a room…which also stops any automations from working with tv. It is also not listed in IDE. Very frustrating…

Yes, the functionality does work. It continues to work on the TV that I didn’t remove. I have a nasty feeling that Samsung have requested this to push new TV sales, and nobody is being very vocal about it.

My kitchen/diner TV is now dumb, and can only be controlled by the remote. It’s a great set other than that, and I don’t plan on replacing it for a while.

However when I do replace it and it’s a choice between something that will work with ST for a couple of years and then become dumb, or a set which will at least work with Alexa for as long as it lasts from an alternative manufacturer, then I know which way I’ll swing!

@Brad_ST it would be really helpful if we could hear it from someone other than a helpdesk rep who may have the wrong end of the stick.

I now have the same issue, I have tried every trick I can think off
Rename Tv
Reset Tv
Add from IDE
Normal st addition method
WiFi
Hard wired
but the Tv refuses to show in St
It shows now only as a directly connected device with zero use or controllability

Tag Brad in @Brad_ST

There must be something that can be done because upto an hour ago I had full control of the tv except on, I deleted the tv from the ide so I could re add it to try and regain an on comand, since deleting its now impossible to re add

1 Like

Looks like 2016 tvs are still using in part the original app or whatever was connected at the back end to make them work

I can now switch ON my 65" 2016 TV but not off and I have no TV controls at all but I do have on !

Lots of trial and all error but by creating a device in the IDE , choosing 2016 tv, finding the tv mac address, adding it to the ide as device network id and remove the : in the mac address gave me a basic Ui in the app where on worked

I just tested with Alexa , the basic ui is honoured in alexa as a device and switches the tv on… no off yet but its something

1 Like

Couldn’t replicate what you did but it’s a start. I couldn’t add it to the app even though google home does see it.

Not really sure its progress but its on… tried the tv on WiFi and on fails, seems to only work with wired net connection

Yup, just double checked, wired works every time, WiFi fails, now if I can figure out off I would be happy, don’t give a sh## about controlling the tvs functions via St, on off would do me

More than likely the tv is accepting some WOL command and it needed the MAC address to find it on the Lan

Just to add here that the add functionality disappeared before the classic app officially retired. I would never have removed the TV (which had been in my devices since I can remember getting it) if I didn’t get a new phone with Android 11. I tried adding it with the classic app when I could (it actually worked with classic anyway, I only wanted to get it working in the new app as I knew classic was going), and the classic app would not find it.

Who knows when it disappeared? TVs which have not been removed still work fine.

I still have one identical TV connected, I wonder if there’s some way to duplicate it and change the mac address? I’ve asked if support can get it back but won’t hold my breath.

Its a shame, I remember when we first started with this new app, the tv integration was great, on off, input select and all available from the UI and automations. It was a marked improvement from classic, the last 2.5 years the tv functionality has got poorer and poorer to the point where tvs can no longer get added

Are you guys now seeing directly connected devices in the ST home page ? If so are you now seeing your tv listed , all be it with limited functionality