zWave and ST plugs troubleshooting (I've tried everything....)

Hi everyone,

Looking for some help in resolving a mysterious issue with ST that has been bugging me for a while.

Hub v2, 5 zWave plug switches, 1 ST plug, 2 GE wall light switches, Sonos, Ecobee3, Hue and Harmony.

I have a multiple xmas and house lights that are controlled by ST. During the day everything works fine and they turn on as designed automatically, however every night (what seems random and at different times) zWave, ST plug switches and GE light switch, with out fail, for the last 3 weeks have stopped working (week days and week ends). My Sonos (hardwired), hue (hardwired), Harmony always work and have never failed. So “that” part of the hub does not have an issue.


  • I have moved the hub around multiple locations (no difference)
  • Removed and added ST and zwave components multiple times in various combinations to see if I can isolate one bad one
  • App actually shows them in the correct state (on -> Turn Off -> Refresh shows on again)
  • changed on / off times to non :00 times (ie 11:47 pm)
  • Logging says commands executed and lights are off (when they are on and the “things” tab also correctly says they are on)
  • Ive rotated all the plugs to different location
  • I’ve tried “repairing zWave” multiple times and that does not resolve the problem
  • If I leave the lights on all night, sometimes they will turn off during the night (most time not) and in the morning I can control them again.
  • No kind of timers or blackout periods on network (Sonos, Ecobee and Harmony) always respond.
  • During the day everything works perfectly (timing a red herring here??)

Now what does correct this (without fail) is resetting the hub. I hit the little reset button on the back with a paper clip and after it resets, everything works again always (until the next evening).

Any thoughts on this? Could the hub be bad? there have been 1 or 2 days in the last few weeks that it has worked normally but that is the exception and not the norm.

Any help or thoughts would be greatly appreciated… its kinda driving me nuts :slight_smile:

Try removing Sonos from the SmartThings setup.

interesting… do you thing the sonos mesh is causing interference? Even if I remove Sonos from ST the Sonos mesh will still be active (if it is an interference problem) or maybe Sonos is too chatty??

The sonos is such a big part of my ST but for trouble shooting purpose I will give it a shot.

Not a mesh problem, there’s apparently some problem with the integration that causes ST to become unreliable. There’s a few threads on this, search for Sonos. You’ll see a lot of people coming onto the forums saying “my z-wave devices stopped working” and it turns out to be Sonos.