ZOoz ZEN20 v3.0

Well, I got the new ZOoz ZEN20 ver 3.0 today, but the joy was shortlived. I was able to get it paired for the main device and that works OK, but not the individual switches (using their new device handler). It remains in continual Checking mode. ZOoz says the issue is with buggy ST changes, based on recent experience I would agree, they did offer a refund if I so desired.

I will keep playing with it, but wanted to share the experience before anyone else gets one. BTW my existing ZEN20 v2.0s are running just fine.

1 Like

Have you talked to Zooz support?

I exchanged several emails because initially, I was having problems getting the device to pair. When I finally got the main device to pair, no switches. ZOoz tech support blamed the issue on buggy ST changes and offered a refund on the ZEN20 if I wanted it.

At this point, I have excluded, reset, and readded the device multiple times using the new DTH and older versions with zero luck.

Maybe @krlaframboise has some insight on this

2 Likes

That sounds reasonable right now. There are a lot of unannounced and undocumented changes going on, and some of them are glitchy. I suspect there will be lot of these over the next few months. :thinking:

1 Like

Out of curiosity, are you using the iOS or Android app? I’ve had issues on iOS lately adding devices with a custom Edge driver, so I wouldn’t be surprised if there is also issues with custom DTH,

1 Like

Agreed which is why not returning it. This version just hit the streets, I was doing a redesign on part of my network and held off for this version to be released. Right now I’m using four individual plugs in a wall rack to meet my needs, so, what I’ve got right now is functional is just not very pretty and a little complicated

1 Like

I am using the android app. It’s not using any Edge driver at all, just the two new DTH’s that are called for in their instructions. In addition to trying to use those, I’ve tried to use the older DTH’s. Zero luck.

I have added a few things using the IOS app lately that do use an edge driver, but haven’t had any problems with those.

I can think of 3 things that could cause your problem.

  1. I wasn’t aware that there was a 3.0 version so the DTH might not work with it. If your issue isn’t one of the ones below then let me know and I’ll talk to my contact at Zooz about it.

  2. You only installed the parent DTH so installing the child handler should solve the problem, but you’ll need to remove the device and add it again.

  3. The onboarding process didn’t assign the device my custom DTH when the device was joined.

The easiest way to see if the device is using my DTH is to open the device in the mobile app and see if there’s a settings option in the menu.

If you can’t see the settings then you’ll need to either repeatedly remove/add the device until it gets assigned my custom handler or change the device to my handler. To change the handler you need to go into the IDE, delete all the child devices, change the main device’s Type field to my custom handler, and then force the child devices to get re-created by opening the device’s settings screen and changing any setting.

1 Like

This is a very fresh release I was tracking it because I was trying to order one of these in January but couldn’t find one then ZooZ let me know that there was a new version about to come out. I got this through smartest house.

I installed both DTH, I have been using them previously because I have four of ZEN20s already on my system. Zooz provided the code for the 2.25 version of the main DTH and the 2.1 version of the child.

I do have the settings menu for the main device, the child devices is where the issue is and I’m including screenshots of both what they look like in the app, and if you bring up the property screen. As you can see, it says it’s not connected but checking. However, if you go to the new web interface, it shows all five of them connected. On the IDE interface, it shows them connected as well but with no history of tome last connected.

If I turn on and off the main switch, all five switches turn off and on and that is reflected both in the log file and the events file.

I did have to change the Driver after pairing as it used the old DTH

BTW the results were thensame for Scan Nearby and Mfg Selection


That’s most likely the issue. This is a multichannel device so you can’t just change the parent handler, you also have to manually delete all the child devices and then open the main device’s settings in the mobile app and change any setting which will force the children to get re-created.

So at this point, I should go back to zero. Also delete each of the five children individually then the main device. Reinstall the main device you can, change the dth. And then bring back in each of the child devices and change 30th as well. Finally, go to the main device and change a setting that will cause them to reinitialize the children?

Kevin,

I was able to get all five switches working, then I blew it all out and repeated the process just to make sure that it wasn’t a fluke. Everything seems to be operational now. This is the process that I used and that I will send back to zoOZ for their information:

Before starting this process, download and create new custom Device Handler’s that zoOZ recommends on their website.

  1. Pair the main Zen 20 device to your SmartThings network.
  2. Using the IDE interface, change the Device Handler for the Zen 20 device to the custom La Framboise 2.25 version.
  3. Remove all five switches and the two USB plugs using the app or the SmartThings IDE interface.
  4. Using the SmartThings app, go to the three dots in the upper right-hand corner of the Zen 20 device and select the Settings option.
  5. From within Settings go to the first option dealing with Channel 1, and change it ( it doesn’t really matter which option you use or what you change it to).
  6. Your App should immediately recognize all five of the Channels/Switches.
  7. Go back to Settings and undo the change you made, unless that’s the way you wanted it.
  8. Select the Settings option again, and this time change one of the USB options.
  9. Your App should immediately recognize both USB Ports.
  10. Go back to Settings and undo the change you made, unless that’s the way you wanted it.
  11. Using the IDE interface, change the Device Handler for the Channels/Switches/USB Ports to the custom La Framboise 2.10 version.
1 Like

Do you have the version one model of this device that doesn’t report power or energy?

If not, then none of the steps in your last email are necessary because you should only have one instance of the custom handler installed…

Also, it’s not “amboise” and there isn’t a version 2.25, but the links in the first post of the topic below will take you to the latest version of the official handlers, even though the preview might show an old version.

If you do have the version 1 device then you would need both handlers, but putting // in front of the fingerprint line of the old handler should also eliminate all of those steps.

If the device joined with a built-in handler then you would have to perform additional steps, but 5, 6, 7, and 11 aren’t necessary.

I had one ver1 and three ver2 at the start of this. I had the original DTH and one that was altered showing a change log whose last entry was 2.2.5 I never had to go through this process for any of them. I simply added them, then changed the DTH.

I apologize for getting the name incorrect and I have corrected it. The version number came from within the code, I was just trying to keep the two versions I knew of separate.

The version ZEN20 I was adding was a 3.0, and of course ST keeps changing the way drivers work. Maybe that is why I ran into these issues and why this resolved them. When I started over from square one (resetting the device and removing all traces from my hub), this fixed the issue.

I appreciate the help.

2 Likes