Zigbee Leak Sensors connect as Zwave Repeaters

I have a large number of devices but I am not even close to being an expert. I have tried to install several leak sensors but each one connects as a Z-wave Repeater and will not function as intended. I originally had this issue with the Samsung sensor and call support. After about 3 weeks, the sensor just began to work. I was told a number of times that the issue was at tier 3 support. Never received any updates or explanation of how it was resolved!
Now, tried to connect a 2nd Samsung Leak Sensor and same issue, connects as a Z-wave Repeater??? Called support, no luck, and they have again escalated the issue. It has now been nearly a week and still no resolution. So, now I tried to connect 2 more Leak Sensors of different brands, and you guessed it, all connect as Z-wave repeaters??? These are the types:
Samsung - not sure of the radio type
Thirdreality - zigbee leak sensor
Tuya water sensor - zigbee leak sensor

Please if anyone can help with this issue?

I’m sure that’s very frustrating! :disappointed_relieved: other people have previously reported the same issue.

Smartthings has its own architecture and it uses the “fingerprint“ of a device in order to match it to the correct Driver/Handler.

If the author of that code puts in a typo they can end up with a mismatch between a device and the driver/handler. There’s also a similar issue that can occur with the capabilities list.

I’m surprised that escalated support hasn’t been able to fix this for you, though. It should be possible to change the device to the correct handler.

Tagging @Brad_ST in case he knows if there’s a particular reason why that doesn’t work with these leak sensors. :thinking:

1 Like

Thanks, I hope he sees and can help. When I connected the 2nd leak Sensor, that was also a Samsung,
I assumed it would be an easy fix on their part?

We’re seeing more of these fingerprinting errors recently with the introduction of Edge drivers, but the fix should be pretty easy:

  • Log into the IDE at https://account.smartthings.com/login
  • Navigate to the My Devices tab
  • Find the troublesome device in the list, and click on it to drill into its details
  • Your SmartThings leak sensors should be Zigbee devices - verify this by checking if there’s an entry in the Zigbee ID field
  • Hit the Edit button at the bottom of the screen
  • Change the Type field to “SmartSense Moisture Sensor” (this is the device type that works for my Zigbee SmartThings leak sensors, though you may need a different one)
  • Hit Update
1 Like

I was the one who looked at your escalated ticket. You have a custom device handler in the IDE under “My Device Handlers” that has an extremely vague fingerprint. You should correct that fingerprint, remove it, or delete the custom device handler. When you pair a device custom device handler fingerprints are checked first and the code below is causing your devices to “match” as a Z-Wave Repeater.

fingerprint inClusters: "0x", deviceJoinName: "Z-Wave Repeater"

You can tell it is pairing with your custom device handler if you go to edit the device type. You can see that the last entry in the drop down is selected. This is a custom device handler vs the standard Z-Wave Repeater device type which would be sorted alphabetically higher in the dropdown.

1 Like

Thanks so much for getting back to me. I am a bit of a novice when it comes to the behind the scenes. I am not familiar with device handlers or how they work or when they are needed? I am not sure how it ended up in my system or why. The Samsung phone Tech did try to walk me though deleting the device handler but, a warning message popped up that a device was connected and the Tech advised not to delete it. Can you help with what device may be “connected” to the device handler so we can determine if I can simply delete it?

Thanks again for any help you can provide!

Thanks for the great instructions.
I did exactly as outlined but no change after i hit update?
Do I need to remove and re-install the devices?

Thanks again.

You shouldn’t need to reinstall the devices (and if you do, you’ll likely end up back at step one unless you first fix the DTH issue that @Brad_ST talked about). The capabilities shown in the app should update after this change, though you may need to close/reopen the app and possibly clear cache as well. Note that this won’t do anything to the name of the device - you’ll have to change that in the app.

I checked and no devices were using the custom device handler so it was safe to delete which I went ahead and did. You should be all squared away except for the “Tuya water sensor”. What model is that? It doesn’t seem to be supported. You can add/remove any of the other sensors though and they should join properly now.


Thank You!
Things are looking much better! The Utility sensor (2nd Samsung Unit) is appearing as “offline” for some reason so I will play with that unit when I get home. After reading the “fine print” no Amazon, the Tuya may not be supported directly, so it may not be able to be used. If I can I will attached the info. No biggie if not, it was a cheap item.

I really do appreciate all of your help! Thanks Again!!!