Z-wave Status Not Updating

Ok, so I have a problem some of the polling intervals on Z-wave switches and updating. I’m not sure if it is because I have a few Z-wave secondary controllers, or other devices but some of the switches are VERY slow to update there ON/OFF status in the devices.

This isn’t really a problem, UNTIL I’m using the Power Allowance app. The switch from delay to runOn has fixed the Command Stacking issue, but if the device tile doesn’t update the status then if someone turns on a light that has a power allowance application for 30 minutes later, and it never knows it is “shut off”, it turns off the light on people.

It is a big reason I went with SmartThings is attempting to save on enegry, but it is pointless if the lights turn off on people in the middle of doing something.

Is there a way to control how often ST polls a switch, can I make it so certain switches poll more often or frequently? Can I change the order of the ST polling the devices?

Does anyone have any ideas??

What type of switch is it? Most switches don’t support instant status since a patent exists on that.

I have several different switches through the house, but the Leviton VRS05 seem to be updating slow. Additionally, even some of the GE 45612 are slow to update. It is like the ST hub is not polling them, because as soon as I manually refresh the ST app they status is up to date. This is causing issues with the “Power Allowance App”, where a light doesn’t know it has been turned off so it doesn’t stop the timer and the next person has the light automatically turn off on them.

Any ideas?

Yah… I have this problem all the time. Whenever I pull the App up after a few hours, the status of Z-Wave switches is never up to date.

Same problem… Cooper aspire switches… Refreshing will always get the current status. ST is the secondary controller.

I have a similar issue with a few devices, a GE Z-Wave outlet, a Kwickset lock, and a couple of recessed Aeon door switches. None of them seem to reflect accurately on the Status portion of the dashboard, but if I go to the “Things” section of the app, the status is always spot on.

Additionally if I try to change the status via the Status page (ie turn on/off the outlet or lock/unlock the door), it rarely works from that page. But once again, if I try to do the same via the Things page, it works 100%

Its almost like there is some bug in the code that controls the status page in that it is not correctly updating on a status change or action.

Currently my status page shows the lock is unlocked, and 2 of the doors are open, but the Things page shows all are locked and closed. Which one to believe?



Basically, the dashboard does not reflect the real status, correct?

A known workaround it to force stop SmartThings on your phone and start it again. I don’t know for sure if the ST crew is actively working on fixing this. I haven’t followed up with support since reporting it in beta. I think I heard it as a race condition which can be tricky to fix.

Correct, in Dashboard the status and/or changes from Dashboard are not accurately reflecting current state. But the Things page does.

I will try the app restart and see if that helps.

Nope, no luck on the restart, Dashboard still shows 2 of 5 (doors) open and 1 of 1 (lock) unlocked, while Things page shows all locked and closed (and verified to be in that state).


Do you have an Android or iPhone?

Try shutting your phone off and turning it back on. There are different ways to “Force Stop” so lets try the brute force method and go from there.

On some of the outlets or switches was to flip the power at the breaker on those to reset, and start getting status to report correctly again. I reset the hub after, i flipped the power on those switches.

You could try that.

@Beckwith, yes I both repowered the phone and force stopped the app, neither helped, Dashboard is still not reporting correctly.

@Morgan, I tried flipping the breaker, no change, Dashboard is only right about 1/2 the time, Things section is right 100% of the time.

Given the Things section is accurate 100% of the time, I dont think the issue is with any of the devices, rather it appears the “app” behind the dashboard is not properly receiving/updating/processing state changes.

My things section is often inaccurate, but pressing the refresh but updates with the proper status.


What phone do you have and what version SmartThings. I have 1.5.8 on my Android. What version hub firmware do you have? Mine is 000.011.00603.

Another thing you may want to try is rebooting your hub. Maybe there is a version incompatibility that requires a hub reboot.

If this doesn’t get it straightened out, I would suggest contacting support if you haven’t already.

Same issue her with ST as primary z-wave and Vera Edge as secondary controller. Z-wave device status is not pulled after action for kwikset door lock. Forced refresh shows correct status. This really needs to be fixed.

I have similar problems - the Z-wave state does not update. The automation then does not work properly. I moved over from Homeseer and where I never had this issue. It screws up my automation schemes. My hot water heater does not come on during good morning procedure as it thinks it’s already on. Same for outside lighting, it leaves the outside lights on all night as it thinks it off and then won’t send the shutoff command. It is intermittent and troublesome.

Yes, when I go refresh several times on dashboard, it corrected itself. That does me not much good.

Just wanted to see if you’ve found a solution for this as it’s a pretty big pain. All of my other devices “push” their status to my app but my gocontrol garage door opener. What used to be one click on my remote is now: Unlock phone, open app, click on garage, see that it’s showing open even though it says closed, refresh, refresh, open… Because it doesn’t push the status I can’t automate it either. Any fixes?

Same issue here with a GoControl/Linear GD00Z-4 Z-Wave Garage Door Opener.
I installed this in the past week and have spent more time questioning it’s status than it would’ve taken to get up and just close the garage. Moreover, I have no faith in knowing its status when I’m remote.

@CaptainDrew and @mytaytay, I know this doesn’t directly solve the issue you have with status, but you could slap a SmartThings multi-sensor on the garage door, and have a second way to know it’s open/closed state. I use that sensor also as a trigger to turn on my garage lights when the garage door is opened.

@bravenel -I think I’m going to have to go that route to gain some assurances. Good tip on turning on the lights when the garage door opens. Thank you!