GE Switches Not Updating Status Reliably

Not sure, but I think this might be a distance/signal-strength issue from hub to device (GE wall switches). Added to my ST hub just fine, and worked initially right after that. But now they will periodically not update (On/Off) back to the hub (or my ST app as I operate the switch manually). Before I get a zwave repeater I wanted to make sure my suspicion was right as this is the first time I’ve encountered this behavior in my home. Switches are in a newly added bathroom upstairs and further away from the hub. Of course, when they don’t update status reliably not only does it impact my ability to understand the current state of the switch, but rules based on the status fail. Thanks.

I have also noticed similar behavior starting around the last app update.
I have a core piston that sets the level to 100% if the level rises above 30%.
This worked great for over a year the It just quit working, I found the level ill not refresh if changed at the switch, I kina fixed this buy adding a auto refresh every 5 second in the piston.

On the flip side, I have another switch only aboat 30 feet and line of sight from the hub that was flaky.
but it would stop responding to commands.
adding a repeater 5 feet from the switch fixed issues with that switch.

This is peculiar - first time to run into this for me. Even tried an Aeon repeater with no fix. I can operate the GE switch from the ST app just fine and reliably every time - ON/OFF. Instant. But when I operate the switch manually, it will not update the hub/ST app. If I hit REFRESH inside the ST app, it updates fine then based on what the status of the physical switch is at that time (On/Off). I don’t want to setup a refresh against this one switch for every 2 seconds - seems a little silly. Did I get a bad switch ? There is another exact same GE switch RIGHT NEXT TO IT in the same electrical box to operate the bath ventilation fan - that one works perfect and as expected. Also another same GE switch in the hallway outside the bath, it also works properly. Thx.

Posting again as I learn, and would appreciate any other long-timers who might have any ideas. Even added a Cree bulb in the room hoping having it as a repeater might help. The Aeon repeater made no difference. Now a couple of times the switches have refused to operate EVEN MANUALLY. But when I refresh from the app or just hold the paddle down for a moment, they begin to operate. Basically just fiddling with them for a moment. I’ve removed and re-added numerous times. Any ideas on why just these switches and so unpredictable ?

You can try a z-wave repair first and if that didn’t work then you can removed(exclude) and add it back. Also try another DTH.

What’s the behavior of a GE paddle switch when you don’t connect the white neutral ?