Z-wave problems - Fibaro door sensor fgk-101


#1

I noticed a few weeks ago, that my door sensors were not detecting the open and close. Upon closer inspection, they did not appear to be changing for anything other than temperature.

I tried reseting the hub, changing the device handler to the default zwave, repairing the zwave to no avail.
Eventually I tested one connector and found I needed to reset and re-add to the network.

However, if I do this to all the devices I will have two problems…

  1. all my applications need to be rebuilt, including the rules engines and this is a total pain!
  2. my door sensors are fixed using the sticky pads not screwed on and you dont get spare pad!

So my questions are…

  1. has anyone else had same problem and did they have an alternative way to get the devices working again?

  2. Is there an alternative way to reset the Fibaro door sensor without using the tamper switch on the rear of the sensor?

Im on a UK V2 Hub btw

Thanks
R.


(Kev) #2

I had exactly the same, I tried a different device handler which worked just fine but sadly it won’t report temp now.


(John C) #3

After seeing the sensor report open/closed correctly again, did you try switching back to the previous device type handler that reports temperature? Did that work correctly?

(I’m playing with one of these and am underwhelmed by the Fibaro DTH. Curious if that’s where the problem lies…)


(Kev) #4

When I did revert back to the original dh, it failed and again the sensor only showed open.


(John C) #5

Any errors showing up in IDE logging, Kev?


#6

ive been playing with this some more…
firstly, I can reset without removing, but it usually takes a few goes to get it to reset.

what i’ve noticed is that the reason the temp isnt working is because the configuration doesnt appear to work!
did some debugging and expected to see some changes when I change the parameters. I guess i need to do some more reading and experimenting.


#7

Mine all worked perfectly till about April.
Since then I get missed sensing of the doors
And No temperature.
Also one of mine was reconfigure to switch as a smoke sensor and now the Zwave config command appears not to work on them.
They changed something in the hub fw and it’s all gone bad for me.

Gonna build a arduino/modemcu device for the smoke detector as I can’t be bothered to work out why code doesn’t work.