Fibaro Door/Window Sensor 2

Trying to use a Fibaro Door/Window Sensor 2 (FGDW-002, ZW5 v3, see here). Z-wave protocol, UK.

Using the mobile app and following instructions from smartthing and fibaro, the device is recognized and added. However:

  • open/close door doesn’t triggers any message.
  • the device appears as a motion sensor class, not as door sensor.
  • temperature and battery levels are displayed (I do not know if they are periodically refresehd).

This is the information about the device I’ve found in Smartthing app:

  • ProductCode 1000
  • ProduceTypeCode 0702
  • ManufacturerCode 010F
  • WirelessConfig ZWP

Any hint?


Write a new device handler based on this one and change fingerprint to:

fingerprint mfr: “010F”, prod: “0702”, model: “1000”

1 Like

I added this sensor and changed the type in the smartthing api to “Fibaro Door/Window Sensor ZW5 with Temperature”. Got it working this way. Only the tamper stays triggered for some reason. Did you encounter the same problem and got it fixed this way?

Hi there,
I’m new to ST hub/world (UK version) and to this ST community so I’m sorry for any mistakes in using the community…
I think it’s the right place to write as, a week ago, I’ve got my first Fibaro Door Window Temp sensor 2 FGDW-002 UK protocol.

I found a specific device handler written by @krlaframboise (thanks so much, welldone!)

It works for me; the device handler doesn’t implement all the parameters yet but the important ones and for me it’s enough.

Someone of you discovered a tamper issue and…yes…it’s the same for me.
For my sensor, I’m pretty much sure that it’s “hardware” related and not software/ST/DTH related.
Based on the Fibaro documents, in order to have the tamper correctly working, both tamper switches (side and bottom ones) must be correctly pushed by the cover (the side switch) or by the surface (the bottom switch).
In my sensor I found that, when I close the abs/plastic cover, it doesn’t push the side tamper switch therefore the tamper functionality is always on, never resetting and so…it’s unusable.
With the abs/plastic cover away, I tried many times to push both tamper switches manually, especially the one on the side (never pushed by my closed cover) and then releasing one tamper switch at a time and it works great.
Therefore I solved by putting a little piece of foam/rudder (1 mm) on the side switch in order to have it well pushed when the abs/plastic cover is closed.
I think it could be a defect of my sensor cover … even if the old FGK-10X serie sensors have a completely different cover that works in a completely different manner with the tamper switches (for the one of you interested there are many youtube videos showing the tamper switches in the old FGK-10X sensor series)…

Hope this could help.

1 Like

I believe the only parameters that are missing are related to alarms, but that was intentional because I believe temperature based alarms should be handled by Smart Home Monitor or a SmartApp like Simple Device Viewer and not the DTH.

If I missed any other parameters that you wanted to use, please let me know.

When I have a moment I’ll look into your original issue to see if there’s anything I can do in the DTH to work around it.