Z-Wave partial then complete failure

Description of issue

I purchased a SmartThings hub a few weeks ago. I had been using a couple of other products to control my Z-wave devices in the past. Most of the devices were added about a year ago. When I added the SmartThings hub, I was able to use the exclusion process from the app, then add the devices. Most connected easily. The setup has been very stable for a few weeks now.

Yesterday a few of my Z-Wave devices stopped responding. They appeared to still be active in the iOS app, but when I pressed to tun off, the status would say “Turning Off” and stay that way. Except one device would change to “Off” but the actual light didn’t change. The same for turning on. These were mostly GE in-wall paddles, some switches, some dimmers, and one fan control. The only other device that quit working was a Kwikset deadbolt. A couple of other GE Z-Wave in wall switches still worked (two of the newest ones).

Recent Changes

I have added 2 of the devices (the ones that were still working) in the last couple of weeks. I was recently given a GE Z-Wave Remote. I had been able to add it as a secondary controller with SmartThings and had it controlling a couple of devices, just to test. My wife and I discovered the issue when I had a breaker off for one switch (which happened to also have the SmartThings hub and it’s network switch), because I was trying to install a new switch. This means the SmartThings hub was on battery backup, but didn’t have a working network connection.

Steps Taken

  1. I tried a Z-Wave repair a few times, and almost every device came up as both failing to repair mesh and failing to repair route.
  2. I pulled the power and batteries from the hub, let it sit about 30 seconds, and plugged back in.
  3. I tried the “repair” button on some of the problem devices. It would say “Checking device health,” and then “ready to replace.” I tried hitting the paddles on the switches a few times, but saw no response in the app.
  4. I killed the breaker on the dimmer and fan control in my bedroom. I read online the GE switches sometimes get in a funky state where you have to kill power to them. This didn’t fix anything.
  5. I unplugged the power and batteries from the hub, and moved it upstairs. I let it sit for about 5 minutes before plugging back in.
  6. I tried removing a couple of the devices. The exclude process didn’t recognize them, so I had to force delete.
    6a. Once the device had been force removed, I tried to use “General Device Exclusion,” but the app would never display an exclusion had happened.
    6b. I used the exclusion process from the GE Z-Wave remote on the devices. It appeared to work, so I tried to add them back to SmartThings, but it never saw them.
  7. Finally I decided to follow the Z-Wave factory reset instructions from the SmartThings site. First I tried to go to each device and use “remove.” All but one failed to actually exclude.
    I held the reset button down for 30 seconds until the flashing yellow LED turned solid yellow. Then I deleted the location from the iOS app and began setting up the hub again.
  8. I tried to add some of my Z-Wave devices. None worked. I tried doing the exclusion process from the app. One did get excluded (That I hadn’t tried to exclude with the remote before), but I still couldn’t get it to show up on the add screen.

I find it odd that a few things work, but most don’t. It’s like I sometimes get signs of life, so it doesn’t seem like the Z-Wave hardware is broken or something. Thanks for any help.

The first thing that I thought of to ask is are any of the other controllers you’ve used in the past still connected either directly or through amazon echo, google home or the ios app? Software fighting over who is boss basically.

Very frustrating!

The first thing I would do is check your account through the web interface, which is called the IDE, and see if the Z wave radio in the hub is marked as operational. You can get there by going to the first page of this forum and then clicking on the link for “developer tools” in the top right of that page.

And in any case, I would contact support, because there will be things that they will be able to see from their side.

To me, it sounds like a hub failure. That’s rare, but it could happen with any electronic device. If so, the exclusions won’t work from the hub because of the zwave radio in the hub isn’t working. But they would still work from the GE handheld, which is what you were seeing.

It’s also possible that there is a critical repeater somewhere, a single device, which has gone bad and so the hub is having difficulty getting messages to other devices on the network.

But again support could tell better.

https://support.smartthings.com/hc/en-us

If by controllers you mean Z-Wave controllers, the previous hubs I have used are all disconnected, however I wondered if setting up the GE Z-Wave remote as a secondary could have done something funky. The issues didn’t show up for a couple of days though, and other people have had pretty good success with the GE Remote.

Thanks for the response. In the IDE Z-Wave is marked as enabled, and I also tried disabling it and then re-enabling to see if that helped, but still no response.

I also sent this info to support, so I’ll see what they say.

Since I’m still in Best Buys extended holidays return period, I’m going to try picking up a new hub and returning the first one to see if that fixes things. As you said, after a bit of this it starts to seem like a hardware issue.

1 Like

I heard back from support, and they suggested moving the hub very close to the devices to do exclusions. So I grabbed a 100ft cat-5 cable (telling my kids this is how we used to surf the web from the couch before WiFi) and I was able to get the exclusions to work, as long as I was within about 5-7ft of the devices.

Then, from the same positions, I was able to add most of the devices back. I thought I was in good shape.

But then it became apparent things weren’t so good. Devices would sometimes respond, but often not. I went into the IDE and several devices show as “offline.”

I tried the Z-Wave repair a couple of times, and I’m still getting “unable to update mesh” and “unable to update route” errors for a few devices.

I’m leaning towards something being wrong with the Z-Wave hardware in the hub, it seems like the range is way too short.

It might be the critical repeater thing JD said, that’s happened to me. Can you tell which device drops off first? Also, next time it happens could you kill all power in your house at the main breaker and see if they come back?