Your device (Samsung M30) isn't compatible with this version

I have a brand new Samsung M30. It is running Android 8.1.0 and Samsung Experience 9.5

When i attempt to install the SmarterThings app (Version 1.7.31-25 ), i get the error message “Your device isn’t compatible with this version.”

Will the Samsung M30 be supported? If so, when? Which devices are supported?

2 Likes

I am having the exact same issue with the same phone. It’s a pretty new Samsung phone so I don’t know why it shouldn’t be supported.

I just found out:

Galaxy M series had been developed based on other software platform and device concept compared existing Galaxy devices. So, some applications/features are not supported and some are changed to downloadable concept on Galaxy M series device.

Representatively, Samsung Pay, AOD feature(AOD is available on only M30 device), Dex, Samsung Pass, Secure Folder, Bixby Voice/Vision, Samsung Cloud, Car Mode, Kids Mode, Easy Mode and Samsung Knox are not available on Galaxy M series.

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.