Yale z-wave lock offline

Hey team…
I have a Yale Smart lock with Z-wave module in AU which has been working fine (LUM issues aside), but all of a sudden it is showing as offline in Smartthings. I can still lock and unlock the door via Alexa voice control which uses the Smartthings integration, so it must be working.
I can still open and lock the door via the physical panel, but within the ST app, it still shows offline, which means routines that I have to automatically unlock the door when I come home, or turn on the lights after dusk when the door is unlocked etc… do not work.
I have tried replacing the batteries, removing and replacing the z-wave module and resetting the ST hub, but same issue.
I have other Yale locks that work fine.
Any help or anyone else experience this?

I have one of my 3 Yale locks that does this. It goes offline, but then about an hour later shows online, only to go offline again. I’ve replaced the batteries, added 2 ZWave extenders (it is the farthest away from the hub), still shows offline most of the time. My other two identical locks, work 99.9% of the time. Like you say, the lock works independently just fine. Since we don’t use this door very often, I just set the autolock to 1 minute and that also works, so at least it’s locked all the time. I’ve only had these for about a month, so other than adding the extenders, I haven’t tried much troubleshooting. These are Yale Assure Lock 2’s with ZWave.

thanks @ericreed5280, I have the Yale Assure SL. I only noticed it because the routines I have on this door stopped working a couple of days ago… finally got a chance to try and see why and this is what I found… offline.
I haven’t seen it come back online again, and wondering if I try a zwave repair or something, or if I need to update the driver to the new edge driver (if it didn’t happen automatically)… to be honest, everything’s been a bit funky since smartthings started migrating to the new platform.
Unfortunately for me, this is my front door which gets used the most, so need it to work reliably. This lock is also the closest lock to the hub, so no extenders needed.
I’ll have another play tonight, but thought if anyone had any ideas that might save me some time.

@Lew66 , have you tried to do a zwave exclude on the device? You mentioned reset but not doing an exclude.

I think order of operations is:

  1. Delete device from SmartThings
  2. Zwave exclude from the device
  3. Factory reset the device
  4. Add the device back to SmartThings
  5. If you wish to use a 3rd party driver for the device, subscribe the driver and add it to your hub
  6. Using the app, switch the device to your preferred 3rd party driver.

Thanks @ScottF100
I will try that but as this is our front door, I might leave it to the last resort so I don’t have to recreate all the codes and routines.
I might also need to work out how to change the drivers etc now that we don’t use the web portal.

I’ve thought about this too. I have 2 ZWave networks as I’m running 2 hubs. I have quite a few ZWave devices in the area where this lock is so I might have better results pairing it with the other hub. The good news is, routines don’t vanish anymore when you delete a device. The routine will stay and a place holder will be put in place of the deleted device, you just click on it and scroll through and pick the new device you just added back in. I usually guesses from a list of similar devices, so that process is much easier now. I wish that had been there when I replaced my hub during the groovy/edge transition. I created placeholder devices by hand to keep my routines from just disappearing, but it’s much easier now.

Also, I switched to the RBoy Edge lock driver for my 3 locks and it provides a lot more features than the base ZWave lock. You might check it out, it supports a variety of ZWave locks including the Yale locks.