Yale YRD220 Zigbee Touchscreen Lock Status not Updating


(Sean Wright) #1

Hi, looking for some help. I recently purchased this smart lock. For search purposes and others who had the issue:

  • initially my lock was showing as UNKNOWN status after pairing with my Samsung Smartthings Hub v2. I could not lock or unlock, nor view the status/battery status
  • I had to log into developer.smartthings.com and modify my device to properly reflect a smart lock for it to show up in the app and allow control
  • my lock now correctly reports a Zigbee lock. I am able to lock and unlock the door from my Android devices through Smartthings

Now on to my current issue - although the device shows and I can lock or unlock, the status of my device does not update on the devices in the app - in my “things” list nor on the dashboard.

I have to use the reload button each time to get an accurate status.

Any idea why my status will not properly update, even after prolonged periods? It is great being able to lock or unlock my device, but many of the notifications or settings I intended to implement rely on a reliable status update - even if it is a few seconds delayed like my switches and lights.


(Bill S.) #2

I would suggest using the Universal Zigbee Lock DTH with your lock. I have the 210 on my back door and it usually updates within 2 seconds using this DTH.


(Sean Wright) #3

Thank you very much for that recommendation - this solved the issue and works perfectly! There are also more options than on the previous one :slight_smile:


(Bill S.) #4

You should also take a look at Lock Manager ([RELEASE] Lock Manager) and @RBoy’s smartapps (http://www.rboyapps.com/).

Glad to have helped :slight_smile: