Yale YRD220 Connected to SmartThings but NOT responding to Lock/Unlock Commands

yale

(Marcel Petitpas) #1

So I’ve got the Yale YRD220 paired with my smart things Hub. It’s about 5 feet away with nothing between the hub and the lock. Pairs instantly, no problems there.

But for some strange reason, It won’t respond to commands from the smart things hub. Lock/unlock doesn’t work.

What I’ve Tried:
-Reboot the SmartThings Hub

  • Factory Reset the SmartThings Hub
  • Factory Reset the Lock
  • Changed the batteries
  • Unpaired and Re-Paired Several Times

My understanding is that it’s using zigbee and not z-wave?

When I try to do the Z-Wave Exclusion, it’s not showing up.

Any ideas are helpful!


(www.rboyapps.com - Make your home your butler!) #2

First you need to confirm if it’s zigbee or z-wave.

When you say it pairs properly, how do you know?
How do you exclude it? If it’s Z-Wave then you can’t exclude it without doing a Z-Wave exclusion either by deleting the device on the ST app or by doing a manual exclusion from the ST app/IDE

Open the IDE, My Devices -> Click on your lock device, what device handler is it using? Also copy paste the “raw description” if you see it.


(Ryan57ford) #3

Did you get it working? I just got the same one (but mine is zwave) and it’s the exact same thing. Its paired up and showing online but cant control anything. Have tried everything I can think of…


(Ryan57ford) #4

I just bought your device handler/ smart app hoping it would work but didn’t change anything :frowning:


(www.rboyapps.com - Make your home your butler!) #5

The DTH will only add new features, bring out additional functionality and fixes a few bugs but you need to ensure basic control works with the stock DTH first. The SmartApp is unrelated and allows your manage users/actions but it will only work if your basic communication is solid.

Power cycle your hub, exclude your lock, remove and reinsert your Z-Wave chip in the lock and ensure that your lock is within 5ft of the hub and then pair it. It’s a good practice to add a repeater within 20ft of the lock to create a strong mesh.

Check your “raw description” and also your hub firmware version.

If it still fails, contact ST support to investigate why your locks isn’t communicating with your hub.


(Ryan57ford) #6

I think I will have to contact ST Support, I just tried what you suggested and it always pairs, but even when I look at the device in the app, battery is null, and it always shows locked. Not real sure where to go from there.

Bummer, I was excited to get this working today.


(Ryan57ford) #7

Not sure if this makes any sense or not but this is the error I get when doing a zwave repair

Network repair for Universal Z-Wave Lock With Alarms [1E]: Failed to update route
Name Value
archivable true
date 2018-06-30 8:52:14.339 PM PDT (2018-07-01T03:52:14.339Z)
description Network repair for Universal Z-Wave Lock With Alarms [1E]: Failed to update route
displayed false
eventSource HUB
hubId 9fd43725-14a8-4d57-8de9-03b6f708bd2c
id 24026530-7ce2-11e8-ae9a-0aae0d636488
isStateChange false
isVirtualHub false
linkText Home Hub
locationId 8b6199a5-09d8-4155-9181-dd9ea65fcdda
name zwNwkRepair
rawDescription Network repair for Universal Z-Wave Lock With Alarms [1E]: Failed to update route
translatable false
unixTime 1530417134339
value failure
viewed false


(www.rboyapps.com - Make your home your butler!) #8

This means your lock z-wave module is not responding to the hub’s requests. I.e. module is too far away, batteries are dead or module is defective
Did you try adding a repeater?