Yale Touchscreen Digital Deadbolt with Zigbee module - device unlocks but status doesn't change, cant re-lock

Hello All

My first post, I trust this is the right area. Any advice welcome with this issue.

I’m trying to set up a Yale touchscreen digital deadbolt with a Zigbee module.

Challenge one, when connecting with Smartthings it just showed up as “Thing” with no options to do anything with it in the Smartthings app.

Having done a search on the forum I found a post which said I needed to change the device type to Zigbee Lock. Did that and I now get the option to unlock / lock.

First problem solved.

Now, if I unlock through the app it dutifully unlocks the door, however the status doesn’t change to unlocked and after a few seconds I get a message saying a network or server error occurred try again later. The door does indeed unlock though.

I’ve put the live logging mode on and this is what is occurring when I give a command to unlock

I’ve done a factory reset on the Yale and repaired with Smartthings a couple times now and still getting the same result.

Any advice, based on the logs, whats occurring? Faulty lock, faulty Zigbee module?

Many thanks

Hmm your IDE logs are showing that you executed unlock but your lock then returned a lock state.

One thing to check before moving to the app, open the IDE -> My Devices -> Click on your lock and do you see the lock attribute state show a locked or unlocked? If you can post everything you see on that page so I can look at the details about your module.

Can you also check if you door is relocking itself after unlocking? Also what module are you using? Did it come with the lock or did you purchase it after market?

1 Like

Hey, thanks for the quick reply.

So, door was locked, I unlocked through the app and this was the logging detail

After unlocking, Ill have to post the device status page as a separate message as it wont allow multiple images from a new user post

I see the status page says message transmitted to device failures is high compared to my other devices. I have ST mesh wifi with a ST motion and Open/Close sensor on the same door and similar ST throughout the house. All working fine.

The door is not re-locking when it unlocks. Once in the unlocked position the app still shows locked and if I try to lock it flashes unlocked, the door makes a ding-ding-ding noise but there is a rotating circle in the app before it times out with the network/server issue message.

I live in New Zealand. I bought the lock about 4 weeks ago then the Zigbee module yesterday. Its a Yale / ASSA Abloy ZBM-2 module. The other reference on a sticker on the box is CCTYLE9855 but not sure if that’s the retailers code.

Okay the first thing I notice is that you have a ghost device on your network. You need to get rid of that and it may be causing issues. This guide is for zwave devices but it may also work for ZigBee devices. Except you should select ZigBee device instead of zwave device for the device handler type: FAQ: How to remove ghost devices from your z-wave network

Except that there isn’t Zigbee repair option neither in the IDE or in the Hub’s options in the app.

Those ghost devices show app, if you have re-paired a non responsive device recently. The “unknown device” is the previous ID or the re-paired device. If you do a Zigbee mesh healing, (power off the Hub for 15 minutes (without batteries if v2 Hub)), than that should solve the issue by itself without adding a new device in the IDE, or you can try to re-add your lock, that should update the mesh routing as well.

1 Like

By the way, what device have you re-paired recently? By any chance is it not an Osram or Cree bulb?

Hey, thanks for having a look.

I’m running a couple Smartthings WiFi hubs to create my mesh network. Both are connected back to my router by network cable.

Under my hubs I only have one hub showing so I assumed this is because the second hub is kinda a “slave” to the master in the mesh network. In the same way, I assumed that the unknown device was the slave hub zigbee it was routing through.

I have other devices, sensors etc also routing through this device and they are working fine.

One thing I have noticed is the high number of message failures on the lock…

Compared to the other devices, such as the motion sensor next to the same door…

Thanks for the message. Only thing really is the door lock which I’ve paired, deleted, repaired a number of times as I’ve tried to troubleshoot this.

Both me and the Mrs working from home today under lockdown rules. I’m running a couple Smartthings WiFi hubs for my mesh network. There will be murders if I turn of the internet at the moment for 15 minutes right now before she gets on conference calls but will give that a go at some point today.

RE my other comment I assumed the unknown device the lock is routing through is the second Wifi hub’s Zigbee module.

I cannot remember fully how the Wifi hubs are operating regarding Zigbee and Zwave, but as far my memory works, I can remember they do mesh the Wifi, but not the other protocols. But I will tag @JDRoberts, he knows that better.

Otherwise what other devices do you have on your Zigbee network? (repeaters)

When the WiFi mesh hubs were first released, the sub hubs did not act as Zigbee or Z Wave repeaters. However, at least for the version that uses plume, that was changed about a year after the initial released with a firmware update and the subhubs do now act as repeaters for Zigbee and Z wave.

That version has never been released in Europe, though. And to be honest I just don’t know when where the other about the Wi-Fi mesh version that is sold there.

1 Like

There is no “Zigbee repair utility“ in the Zigbee spec. It just doesn’t exist. Nothing to do with smartthings. :sunglasses:

Instead, you do a “Zigbee heal” by leaving all of your zigbee devices on power except the hub. Take the hub off power (including removing batteries if it has them) and leave it off power for about 20 minutes.

This will cause all of your other Zigbee devices to go into “panic mode“ And then when you put the hub back on power The mesh will be rebuilt from scratch. So essentially the same end result as a Zwave repair is for Z wave, but it’s done a different way.



OK, so i tried removing the ghost device option. Also cycled the power on the “slave” hub.

Now says we are going a direct route

Tried a door unlock from the app. Door unlocked. App stayed showing locked. Here’s the events

Trying a lock from the app, when it was already showing locked, I hear the door ping but not lock and the app gives a network/server error try again later. And here’s the logs

I’ve also reached out to Yale support, waiting for them to come back to me.

Thanks. Other devices are:
5 Samsung motion sensors
3 Samsung open/close sensors

I’ve also got Hue lights, a Sensibo heat pump controller, Yeelight light strip and a ISmartGate for the garage doors but I guess they are all wifi devices separate to the Zigbee

Where did you found that DH? I am just looking at the code of the official Zigbee Lock DH and the debug log’s comments should start like this: ZigBee DTH - .

Never mind, it is too late for me, and I just cannot recognise what is written on your images…

OK, thanks. I have the version with Plume, model ET-WV525BWEGAU. It was released in Australia last year. I’m in New Zealand and had two sent over. Firmware is up to date.

New Zealand only got, what I think is the V3 hub, released only this year. Model GP-U999SJVLG.

Have you managed to make it work without any issue?

Unfortunately not. Yale / Assa Abloy in NZ haven’t got back to me either after initially raising the issue with them last week.

Our COVID lockdown policy in New Zealand has been changed from today so we’re allowed back in to shops. I plan to box up the Zigmee module and return it as faulty, given the high number of message failures being reported in the IDE.

If a new module produces the same issues then it perhaps gives a strong indication the lock itself is faulty, which i’ll press Yale to swap out.

Given I have no other issues with any of my other connected devices I think its unlikely to be an issue with Smartthings.

1 Like