Yale Keyless Connected Smart Lock shows 10% battery with brand new batteries

Same here. 6 locks. 3 report bad battery

Ah, you’re ahead of me as I’m still on my first set of AAs on each of my locks. At least it is showing something different even if on the day of failure.

It’s not pretty though

Just installed a new z wave 2 controller. I was hoping it would fix the battery report issues but no luck. It was showing 10% with the old one and now shows 1% with the new one.
To be honest i bought it as “never used” from a locksmith off eBay. If I had bought it from yale or Amazon I would of sent it back and got a different brand.

Same. I sent @yalesecurity a tweet today 07/03/2019 asking for an update. Such an important feature being left unresolved is unacceptable. If I had known I would never have made the purchase from Yale.

1 Like

Yeah, me too.

Yale UK seem hopeless with regards to (smart) technology. They are way behind their US sister company.

The UK only offers Z-Wave and their proprietary module, the US offers also Zigbee, HomeKit and August Connect modules. The US has also just announced a new August derived smart doorbell with integration to other Yale US locks fitted with August Connect module or August locks.

(Assa Abloy owners of Yale bought August.)

The only reason I looked at and bought a Yales Keyless Connected lock is that it is the only smart night latch type lock on sale. (Unless anyone here can suggest an alternative.)

The Keyless Connected is even worse than the Connexis L1, there is no app for it and you cannot therefore do the smarter things to manage codes etc. Also in my and a couple of other cases I cannot get the Keyless Connected lock to work with a Z-Wave version 2 module. I have tried three version 2 modules, two Smartthings Hubs but only one lock. The lock does work however with a version 1 module.

1 Like

They’ve asked me to DM them so have.

And here is @YaleSecurity response… “not got any new firmware available”

Things seem to have got worse as in addition to not knowing the battery level the lock now seems to be reporting “Ed” up to twice an hour. Hence batteries draining faster but we still don’t know! Anyone else getting this message?

My batteries drain at an alarming rate and I am down to replace them every couple of weeks now.

Not checked for the Ed message (whatever that is) but will do

I came across this thread after my Keyless Connected Smart Lock developed a fault… sporadic brief low battery indication (at random intervals, sometimes just a few seconds) even with brand new batteries - but it would appear that this isn’t a good Zwave-based lock for integration into home automation.

Any suggestions for a better replacement?

Dear Samsung Community,

I have been contacting both Yale and Samsung SmartThings over the past month and they have been sending me back and forth to each other saying this is the other’s problem to fix. I have three keyless with z-wave module 2 purchased in Nov 2019. All working well except battery always showing 0% for all of them on the smartThings app.

Yale told me this is a smartThings display issue, while Samsung told me that this is a z-wave module firmware problem. So I managed to get Yale to deliver a new z-wave module, make sure my smartThings is updated to the latest version. Removed, re-installed and reconnected the lock and it is still the same issue (showing 0% battery). Yale told me that this is now a Samsung problem and there is nothing that they can do.

Did anyone manage to resolve this? Or this is just a product fault when using the two together that can never be fixed? If so, I will have to return everything and just move back to the good old lock and key system.

Hopefully technology will improve in the near future…

I am glad it’s not just me that got this. I’ve been ‘coping’ with this for a couple of years now. Sad to see no resolution in spite of multiple firmware upgrades. The old adage ‘if it ain’t broke don’t try to fix it’ spring to mind as when I first got this lock it worked (eventually) with SmartThings perfectly and only gave me low battery warnings when it actually was running out. Now in these days of lock down I am constantly replacing the batteries every three weeks in case I get locked out!

@davidchow
I could not get a Yale Z-Wave v2 module to work with Smartthings at all. I tried three different v2 modules and two different Smartthings hubs. A v1 module pairs fine.

I gave up on the v2 modules and I also had the same buck passing between Yale and Samsung. I currently plan to try the announced Yale Access Module. This is (will be) the the UK version of the August module. The battery issue with the Z-Wave module is a ‘known’ issue although I thought it was more that it either showed 90% or 10% with no accurate indication.

I am hoping all these woes will be addressed by the new Access Module and that it will add features missing currently from the Connected Smart lock like being able to control the access codes in software. This is possible with the Connexis L1 but not the Connected lock. The Access Module will also add HomeKit support.

1 Like