Yale Keyless Connected Smart Lock shows 10% battery with brand new batteries

I just installed a Yale Keyless Connected Smart Lock (http://www.yale.co.uk/en/yale/couk/productsdb/smart-locks/Keyless-Connected-Smart-Lock/) and it connected to my SmartThings hub fine and seems to be working. However, the battery level in the SmartThings app and the SmartThings web interface both show 10%. I have tried the set of batteries that came with the lock and another brand new set but both show 10%. I am assuming this is a formatting error and 10% actually means 100%?

Same here, just installed the Keyless today and i would come to the same conclusion as you - anyone else have the same ?

I contacted Yale support about this issue and this was their reply:

“This is a glitch which is being worked on by the Smart team and Samsung. Apologies for this I know it can be a nuisance.”

I am tempted to just multiply the reported value by 10 in the Z-wave lock device handler code to placate my OCD but this doesn’t really fix the problem :frowning:

Same problem here…Just installed the hub with the Yale keyless lock…Both work fine but with the battery display problem confirmed by Samsung support chat.

I have also noticed that you only get notifications from the hub when the lock is unlocked with a code but not with the card or tag…According to Yale this is a Z wave integration issue that they are aware of but with no plans to include it any time soon if at all.

To me I would like to see this included within the notifications so that a complete log of the door entry is obtained.

Yes, disappointingly i found exactly the same thing:

I have the same battery issue!

but I checked the logs and the device itself is sending through the wrong battery info… so I doubt they can fix it by “working with the smart team and Samsung”. The device itself will need a firmware update or something. I have no idea how they can do that because Smartthings doesn’t support OTA updates for Z-Wave… and this isn’t even a ZW+ device. Times x 10 probably wont fix the issue because I’ve never seen it report any info other than 10%… never 9 or 8 or anything like that…

I think we’ll have to put pressure on them to replace our hardware

Well its now January 2017 and this problem is still there. SmartThings, it cant be that difficult to include this fix in one of your updates.

Its been showing 10% since changing the batteries so I don’t think it updates at all

It appears to be a problem with the Yale lock, i’m afaid. As @AdamV says, SmartThings is just displaying the value reported by the device. So, unless there’s a way of updating the lock’s firmware it looks like we’re stuck with unknown battery levels. Just keep a 9V PP3 battery on you at all times in case you get locked out when the batteries go flat :wink:

Now Feb 2017 and this continues. My two new locks report 10% battery remaining. This is is a real pain as both locks are in a remote location.

Does anyone know if once the lock indicates low battery whether this triggers a zwave status of low battery or similar? At least this offers some protection.

What device handler are you guys using? The generic Zwave Lock or a specific Yale handler?

I’ve had a play around with the Yale lock and it doesn’t seem to report a battery level via Zwave. I don’t know if there’s a specific command to trigger a battery status reply but I can’t find one.

It does, however, trigger an even for “Batteries replaced”, so I updated the device handler to make this even set the battery level to 100%.

I can see other handlers for “Battery low” and “Battery Critical” but I don’t know the Yale lock will actually fire these. Hopefully, it will and these events can be used to set the battery level to 10% or whatever. I’ll find out in time and update this thread.

I’ve made a temporary fix and started my own discussion about some of the technical points here:

Hey everyone - I contacted Yale again and this time I just kept emailing them everyday, until eventually they sent me a replacement lock.

I have just fitted the lock and my ST app is showing 90% battery!! so that looks like the new lock has this fixed. I’ll keep checking over the next few weeks / months to make sure that it does go down from 90% and that it isnt just sending that to ST!!

Hopefully you can all get replacements as well.

Hi. Can you confirm that the battery issue has been resolved in the new model?

No it definitely has not been resolved. The new model just permanently shows 90% rather than 10%. Its still the same issue - my door lock ran out of power the other day and I had no warning that would happen because it always displays 90%. I tried sending a custom command to the device to get it to update the battery info more often… but it still does not.

Thank you for the follow up. I have opened a ticket with support about the
smart lock SmartApp not working for me and hopefully will get answers about
the battery issue too.

Have you had any luck? I’ve just moved from Vera, and am now faced with this issue.

We have the same issue with 11 locks connected to Vera systems. We simply rely on changing the batteries when we get an alert. Some seems to report 10% & one or two report 90%. None ever change!

It’s infuriating that we don’t know when batteries run out! we should be notified, there’s supposed to be an alarm on the lock to notify you - I had nothing. I had to enter my code 10 times before it let me in because it didn’t have the power to unlock the door, yet showed 90% as per usual! ridiculous!

Since this 10% battery report problem is still happening can you share your custom device handler and any tips for adding handlers for “Battery low” and “Battery critical”.

It would seem a reasonable workaround would be to use “Battery replaced” to set to 90% and “Battery low” to 20% and “Battery critical” to 10% or some similar pattern so one could see the figure at least change between these three levels and plan accordingly. (Assuming the additional handlers work.)

Hmm, on a different aspect, there is now a Z-Wave version 2 module for the Yale Keyless lock. Has anyone tried this to see if it has the same problem? This module uses Z-Wave Plus.

Yes set up Yale Keyless lock and Yale Z-Wave module 2 in Aug. has gone through 3 west of AA batteries since with notification of 90% until day of fail on low battery when it shows 1 (not sure if 1%). Not impressed and will watch next set of 4 x AA like hawk despite lock being used 4 x a day.