How to reset Yale LOCK With Z-Wave from ATT Digital Life?

I have a YALE TOUCHSCREEN DEADBOLT LOCK With Z-Wave. Is it compatible with Smartthings? If it is am I going to have full functionality of the lock or simply lock/unlock?

Thank you.

@borism

According to the list of tested things, these Yale’s are tested and working:

http://build.smartthings.com/compatible-devices/

Touchscreen Deadbolt YRD220-ZW
Touchscreen Lever YRL-220-ZW
Touchscreen Deadbolt YRD210-ZW

Assuming your model is one of these, I’d say you are good to go.

I don’t have a Yale, so I can’t say for 100% sure, but I strongly suspect that you will (at this time) only have lock/unlock abilities. I know that’s all you can do with the Kwikset (I have one) and I’m almost positive that’s the same with the Schlege (Someone else reported this), so I’d have to think the same is true of the Yale right now.

Thank you for your reply and for the list. My lock is Yale YRD220-ZW-619 Real Living, looks like it is working based on model. Will test.

One thing to be aware of: You may need to re-enter codes are connect to SmartThings.

Again, based on my kwikset, any codes entered prior to pairing were erased and needed to be re-entered.

I have a Yale lock and it’s not working well with SmartThings. It doesn’t poll properly, rendering it useless. I see that Revolv promotes the Yale lock on their site. This would be a killer feature and probably the most helpful. Has anyone experienced success with this lock with ‘open when I arrive’?

I have had no problems with the Yale lock yet, has locked unlocked every time have used it, infect has worked great with presence sensor too.

My lock still does not work well, I gave up for now.

I have the Yale deadbolt and the SmartThings app on iPhone can be used to lock/unlock the door but the big problem I have is that the SmartThings app never shows the proper status (always shows unlocked although I’m looking at the door and it’s clearly locked).

Hello,

I’m part of the android beta program and I reported the uncorrect <status> problem to Smartthings.

Here is my posting:

This is not an issue with the current beta release per se, as it has been there for a while.

I have a Yale YRD220-ZW-619 lock. Every time, I lock it thru smartthings, its status passes from “locked” to “unlocked” in a very short time (about a second) although it is physically locked at the door. The status of the lock is not in sync with the hub. Upon Smartthings support’s recommendations, in order to correct this issue, I tried to exclude the lock and re-insert into the hub several times without success.

At the end, Smartthings supports referred me to yalerealliving support to update my firmware. After talking with yalerealliving support, they confirmed to me that the real issue is the timeout that is used to interact with the device.

After further testing (many trials and errors), I found out that the issue is within the z-wave lock’s lockandCheck function.

I created a custom lock device (based on the “lock code change” smartapp developed by a fellow developer, see https://github.com/bigpunk6/device-type.lock) and changed the timeout used by this function from 4200 milliseconds to 2200 and now the lock’s status is correctly reported to the hub. I left the “unlock” timeout unchanged as the problem is only related to the lock event.

My request is that the z-wave lock device’s code should be changed accordingly. This may have to be tested with other types of locks as well. Maybe, each lock device has its own timeout requirements…

I have a similar issue with Yale YRD220-ZW-619 where the lock status is currect for a period of time (around 4 hours) and then it goes to unlocked for some reason. If I lock it again from the app everything works even though the door has been locked the whole time. The lock attempts to lock itself again. Then it is the correct status for another period of time. I might try the custom lock device idea to see if that helps.

I have two Yale YRD220-ZW-ORB (front & back), and it was flaky (and almost useless except for the built-in functions) on ST during summer & fall 2013. But an update in December(ish) 2013 seemed to cure everything. It unlocks when I arrive, and informs me when it is unlocked by a code, and which code. It reports the correct state, and tells me in the tile’s activity stream if it’s jammed. It does not tell me when it is opened from the inside/deadbolt switch (or via a key, but I threw my keys away so that’s not an issue unless someone picks the lock). But I have a door open/closed sensor as well, so if the door opens when it’s not supposed to, I’m gonna find out. Overall, very happy with the look and functionality of the lock. One of my favorite, prettiest, and most useful z-wave devices.

Hey @radiogavin - Sorry to wake an old thread. Your answer is the most sound I’ve found into my worries of Yale + ST. Has there been any improved functionality since December '13 with ST and the Yale lock?

I’m only on the fence between Revolv and ST because Revolv allows their users to add/remove codes to Yale locks through the mobile application. Is this possible on ST? Any chance I could see a screen shot? - Is it similar to this -> http://revolv.com/new-feature-smart-lock-user-codes/

I am having a similar issue with displaying the correct lock status. I added two locks to the network (adding to the network went smoothly, though for one there was an error during the first install so I had to drop it from the network on the lock and exclude it from ST); one so far displays the correct status, the other (the lock I had to install twice) does for 3 seconds then changes without a physical change on the lock. Has anyone found a way to correct this?

I am having the same issues! I was able to get the lock (mine is a YRD240-ZW-619) to show up on the ST app (using iOS) with its own tile, but it was always showing green for “Locked.” I removed it, along with “unpairing” the Yale touchscreen. However, now I can’t get the Yale to unpair - it keeps returning me to the prompt area (7#) where I can unpair, but when I touch the command (3#), it doesn’t do anything… Is there a reset function (to default)?

Also, is there a walkthrough or tutorial for getting this lock to work in ST? Thanks in advance!

I had similar issue with pairing, then unpairing with my YRD240. Solution was to unplug the hub for 10 seconds, then perform an unpair, followed by pairing. Make sure hub is within 10 feet of lock initially. That fixed issue for me. Once done and lock is in place/installed, perform zwave repair to update the net stats.

I now have it working just fine! I ended up taking the lock off, putting it next to the ST hub (about 2 feet away), and initiating a device exclusion from the ST app. Then I was able to unpair the lock and re-pair it to ST properly. Apparently, this was the issue… Thanks for the help!

Does anyone know the status of this question?

It sounds like ST supports the Yale locks and they work correctly, but does it support managing the user codes? This is an important feature, since I currently use my Revolv to manage user codes for a rental property and am looking to move from the defunct Revolv to ST and am trying to make sure everything I have in place with Revolv will function in ST.

Any thoughts or insight will be very helpful. Thanks

I just want to highlight what @jgm1937 stated and add some assistance to anyone migrating their Yale YRD210-ZW-619 - Z-Wave Push Button Deadbolt from one Z-Wave system to the other. This same process should work for most other Yale locks that use the same Z-wave module.

I had tried doing the exclusion at the lock itself (MasterCode + # + 7 + # + 2 + #)

I had also tried just running a general exclusion (From the Dashboard, select the three bars top left, Select, the Gear icon, under Hubs select your Hub, Select Z-Wave Utilities, select General Device Exclusion) Neither worked.

The key is doing BOTH at the same time. Put your lock into exclusion mode as above, THEN start the general exclusion on your SmartThings Hub within 30 seconds. You will then get visual and audio confirmation at the lock that it is excluded.

Have both devices within a few feet of each other for the most chance of success.

To Include, get your SmartThings hub in inclusion mode (i.e. add a device).
Then MasterCode + # + 7 + # + 1 + # on the lock and it will pair. Again visual and audio confirmation on the lock should show up.

Hope that helps someone!

I have a yale deadbolt and the module says zigbee. Will this work with the hub?? I had the deadbolt working with my security company called rogers and I don’t have them anymore.

Could i buy a zwave module??

So, I’m rather new to SmartThings, but I purchased the Yale lock and a SmartThings hub. This is my first device and I’m not sure what I’m doing wrong.

What I’ve done:
Set up the HUB and installed the app (Windows Phone)
I configured the Yale Touchscreen Deadbolt with the Z-Wave adapter
I added the lock to my network (yay!)
When I go to lock it or unlock it, it gives me “an unexpected error” (well, that’s helpful)
If I manually lock or unlock the lock, it correctly reports the status in the event history
I removed it from the network (both via the app and the lock, so that I knew it was gone) and re-added it
Still the same issue.

I know it’s connected because the status changes. But I can’t control it through the phone app.

Between posting this and getting a reply, I’ll likely have set up a dashboard app on an old computer which may or may not work. Any help or advice would be appreciated.

[I’m a programmer, so I’m fairly used to figuring out tech. It’s possible that I’ve done something completely boneheaded, but only moderately so.]