WS15Z - On/Off Status is not updating in the App when pressing the switch

I can control the switch from the app just fine, and if I go directing in the settings pane for that specific switch and press refresh the status will update. But refreshing all of my Things will not update status.

I also notice that the LED status light settings does absolutely nothing to change the LED state. And suggestions?

I have some WS500Z switches I plan to install next, but I want to make sure these things work properly before I move on.


It happens to me too occasionally; removing power from the switch for a few seconds fixes it.

Thanks, I tried resetting the switches with the breaker box, no luck, they still work the same. I have also tried Repairing the Z-wave network half a dozen times with no luck. My hub firmware is 000.013.00005 appears that is the latest.

Linear switches can only display led while on or off. You can’t force them off. :frowning:

The device type is kinda wonky/broken for this feature.

Thanks. I don’t really mind the default LED status light, although it would be cool if I could easily toggle the setting.

This real issue to me is I will manually turn on a light at the switch and the light will show as off in the app. Which basically kills the ability to use that light for “Things Quiet Down” mode changed. And if I toggle it in the app I need to toggle it twice to get it to do what I want. It seems no one else is having this problem? So it’s not the device type issue?

So I’ve rebuild the z-wave again, and I powered cycled the hub. And that seems to have fixed it for my 2 on/off switches.

So I went ahead and installed my 2 dimmer switches, and I am having the same problem, also Linear, WD500Z. I have the same issue. I’ve tried rebuilding zwave, and powercycling everything with no luck. This issue is even worse, since with these switches if I turn them on at the switch, the app just cannot refresh to update the status, and doesn’t work at all to shut them off, so I loose control inside the app and have to go turn them off manually.

Any suggestions? I am super frustrated :smile:

Did you ever find a solution to this problem?

I am just starting out, and so far only have two Cooper Aspire RF9540 dimmers in the system. Both can be controlled properly from the app on my iPhone. One of the switches updates the app instantly when operating from the switch, but the other will never update the app from operating the switch locally.

When controlling from the app, both switches even say “turning on” or “turning off” for a few seconds while the dimmer’s slow on/off function is running, then both switches will correctly report “on” or “off” in the app.

The two dimmer switches are about 15 feet apart, the one that works fine is the closest one to the hub.

I’ve tried “z-wave repair” and power cycling everything several times, but the problem still exists.

After several times removing power to the switch and power cycling the hub, it fixed itself

Thanks. I now have six RF9540’s in the system and four of them update the app perfectly. The other two dimmers never update the app when controlled locally. I have been moving dimmers all around the house, and proximity to the hub does not make any difference… it is always the same two dimmers that don’t update status. I’m hoping Cooper will get back to me and let me know if these two are defective, or if there is something I could do to enable instant status updates.

Since all six dimmers are the exact same model number (and version), I don’t suspect the hub is the problem… but who knows???