Withings Scale Problem


(Jeff May) #1

This may not exactly be a SmartThings issue, but I have spent hours working with Withings and it is definitely related to SmartThings.

I bought a Withings scale WS-30. It sent data to the cloud for ~20 days.
2-3 days after I installed SmartThings hub it wasn’t connecting.
I have probably exchanged 10-15 emails with Whitings customer service.
I tried every bit of advice (hours) and it would not connect to my router. (Verizon stock wi-fi router)
I returned it and received a new scale which connected for 2 days. Then never again.
I took my scale to work (2 different sites and routers and it works fine).

I have cleared and reset everything incl DHCP router tables, Withings app on phone.
I never was able to get a factory reset to work… probably tried 20+ times.


(sidjohn1) #2

How odd… I have had a WS-50 and SmartThings running for over 1 yr together without any wifi related issues. The only way i can think of that the 2 could be interfering is if your wifi channel and zigbee channel are using the same frequencies. The pic below shows the wifi and zigbee channels that do not over lap. so if you are using wifi 1,6 or 11, then zigbee 15, 20, and 25 should not interfere.
You can find your zigbee channel on your hub by going to https://graph.api.smartthings.com/ > My Hubs. on that page you will find “zigbeeChannel:” Mine happens to be 15, which goes well with my wireless networks on 1 and 11. To my knowledge you can’t change your zigbee channel, but you should be able to change your wifi channel on your router to something that doesn’t conflict. The only other thing i can recommend if you still feel smartthings is causing your scale to fall off wifi is to power off your hub for a few days. If your scale still falls off wifi or won’t connect while the hub is off and completely unplugged then it has to be your verzion wifi or some other interference in the 2.4 Mhz spectrum. A secondary access point or wifi extender maybe able to help.


(Dawn Fairbro) #3

Interesting. I just started have the same problem with my Aria scale. Had it connected (to the same router) for over a year, fell of network and now it will not reconnect (I have tried repeatedly for the last 4 weeks). I was told by fitbit customer service to "Please open your router settings and assign a unique wireless channel to each of these two frequency bands, making sure that the channel used for 2.4 GHz is lower than the one chosen for 5 GHz. Also give the two frequency bands individualized SSID names, so that you can specifically choose the 2.4 GHz SSID during the Aria setup process."
Oh no…I have to many things connected to my wifi to do this. This would take days to complete. Aria is now being used as a heavy door stop… :smile:


(Jeff May) #4

I don’t know that it is because of the SmartThings, I have SmartThings hubs at work too (although I only have my scale there one day a week.) I only have 2.4 GHz at both sites. I posted it here because

  1. It could be a really wierd ST issue
  2. It was a ST blog that turned me on to Withings scale
  3. I tried everything else and there are really smart people here.

(sidjohn1) #5

:relaxed: I love IT and all the incomplete info that is out there. Unless you live in Japan you don’t have a choice in this matter. The lowest 5ghz channel is 34 in some places, in the US, Canada, and most of Europe the lowest is 36. 2.4Ghz wifi is channels 1-14… Globally. Your 2.4 Ghz network will always be on a lower channel than your 5Ghz network… unless you live in japan.

Your fitbit aria is an 802.11b only device. It has no idea about 5Ghz anything, i doubt SSID naming will be an issue… but it is possible if your router is screwy. If you are using your ISP’s router/wifi combo, you may of received a background firmware update that messed with your settings. I would double check that your wifi is still set to b/g or b/g/n modes for your 2.4ghz network.

The reason i doubt SSID naming is an issue is because my WIFI setup is a bit more complex than most due to all the 2.4Ghz interference in my area. I have 2 Access points, 1 that broadcasts on 2.4ghz channel 1 and 5ghz channel 40. The other broadcasts on 2.4ghz channel 11 and 5ghz channel 153 and all 4 networks are broadcasting the same SSID. I have 29 wifi devices that just work and 1 that won’t auto swap access points if 1 goes down cause i’m messing with it. :smile:


(Dawn Fairbro) #6

@sidjohn1 Thank you, I thought that sounded like a lot of " we (fitbit) don’t know what is wrong so let’s have her change everything first"

I have a Comcast modem (which one, I don’t remember) and a Linksys Smart wifi router. No combo. Did double check that wifi is still set to b/g or b/g/n modes. I am thinking I just have to many things in the house and getting lots of interference… However I would love any other suggestions you may have :smile:


(sidjohn1) #7

Honestly i think the best course of action both of you (@dfairbro1 @jmay33 ) can do is first make sure your wifi and zigbee aren’t interfering with each other by checking the zigbee and wifi channels being used and ensuring your Smartthings hub is at least 6ft (more is better) from your wifi/router. This rules out smartthings from being an issue. If that looks good update your wifi/router to the vendors latest firmware and double check the settings afterwards. Finally if all of that is good i would goto a store with a good return policy and pick up a replacement wifi/router and monitor the behavior with new wifi hardware.


(Dawn Fairbro) #8

@jmay33 Jeff, did you ever get the scale working? I finally got mine to work. What I did was when I entered setup mode instead of putting the same scale name (Dawn) I changed it. I don’t know why it worked, but it did. Just wanted you to know…


(Jeff May) #9

Nope. I tried what you said too, I removed Withings app, reinstalled and said that I was a different family member.
I can get it to work every time at two locations at work, but just not here at my house.

I get Wi-fi error: No Response


(Dawn Fairbro) #10

Jeff,

I am truly sorry to hear that. I wish I could offer you are suggestion that would work :frowning: . I think I just go lucky fixing mine


(Jeff May) #11

OK, so I was able to get my scale working again by changing the SSID and changing the security from WEP to WPA2. (Not sure which thing fixed it, I did both at the same time.)


(John Lord) #12

i’ve seen a lot of problems with an ssid with a space in it.