WiFi 5Ghz and 2.4Ghz on separeted SSIDs

Hello there, my first post here.

I have de zigbee and wifi mesh hub, but i was not able to separete the 5ghz and 2.4Ghz wifi SSID networks. I have some iot devices (like sonoff) that works only on 2.4, and if i´m close to the hub, my mobile conects to 5Ghz, once it´s the same ssid name for both.

Appreciate any tips.

1 Like

Surely they’ll only connect to the band they are designed to connect to? I’ve never found this sort of thing a problem. My phone connects at 5Ghz and is well able to communicate with devices that need to connect at 2.4 just as long as the SSID and passwords are the same for both bands. (and that is only important while setting up)

It’s not uncommon for devices to fail to connect when both SSID have the same name. If you have older 2.4GHZ devices, the best thing to do is give them their own SSID to connect to.

I have same SSID for both frequencies and have found that if I turn off the 5Ghz the 1st time I connect a new device, I can turn the 5Ghz back on without issues after even if 2.4Ghz device loses connection and has to reconnect.

1 Like

I don’t think that’s possible with the SmartThings brand Wi-Fi mesh system, is it?

That’s true of many Wi-Fi mesh systems. Both bands are given the same SSID.

Back to the original question…

It’s true that your mobile phone will probably always connect to the 5 gigahertz if it’s available. But that shouldn’t cause any problems with controlling your 2.4 MHz Once everything has been connected to the system.

Specifically in a smartthings system your mobile doesn’t Communicate directly with the hub anyway. It always goes to the smartthings cloud.

So when you have a cloud to cloud integration, your mobile can be on a completely different band, or you can be outside of the home several kilometers away, it’s all the same thing. Your mobile talks to the smartthings cloud, the smartthings cloud talks to the device cloud, the device cloud uses the Internet to talk to the device.

The only time you should run into a problem is when you are doing the initial set up for a Wi-Fi device. Many of these do require that your mobile phone running the device manufacturer’s app be on the same network as the device, and again, for many of these, it Has to be the 2.4 band.

So that’s when your mobile phone connecting automatically to your 5 GHz band can cause a problem. :scream:

Some routers will allow you to turn off the 5 GHz band temporarily, but I don’t know if the smartthings Wi-Fi mesh router does. It might not.

The Workaround Tip

The workaround is the one you already mentioned: move far enough away that your mobile phone can’t reach the 5 GHz band and it switches itself to the 2.4 band. That’s awkward, but it should work for the one time set up.

And again, once it is set up, in a smartthings environment it shouldn’t matter what band your phone is using.

A lot of people run into this when trying to set up some of the video doorbells or cameras which only work on 2.4 MHz.

Hopefully if there’s an easier way to do this with the smartthings brand Wi-Fi mesh router, someone will mention it. I’m not that familiar with that model.

We should also ask which of the two models you have. Do you have the one that uses plume for network management? Or not?

But it’s still the same network, surely? I’ve got devices and computers connected all sorts of ways to my LAN but it’s all the same LAN and they all see each other. Only problem is some meshes allow you to make a seperate subnet from your wired hardware, and some (google wifi) force you to do so. But I don’t think that should apply to two different wifi bands on the same router or mesh.

I think it’s that some smart devices when you set them up, they query your mobile to get the SSID and password from it - then of course it’s no good to them if your phone hands them the details of the 5Ghz band.

Technically it’s not The same network, but it’s managed by the same router.

For security reasons, there are some devices that require that during set up you be on the same network branch, you can’t even be going through a Wi-Fi extender. Those are the ones that tend to run into this issue, But only during set up.

1 Like

Thank You @JDRoberts. You were the only one that got what i meant.

Yes i use the smartthings (Zigbee + Wifi). I can use plume to manage the network on this device or use the samsung instalation wizard.

I was trying to figure out another way but move far away, but i think there is no way out. :frowning:

1 Like