Why I can’t connect to a zigbee smart plug

Hi all
I am new to all this but have just got myself a V3 hub as I needed the Zigbee capability.
As I have some Develco smart plugs but when I try and connect on add devices it keeps saying can’t find the device and both prices of equipment are zigbee certified, so why is this happening can anyone help

1 Like

Perhaps, but are they on ST’s list of supported devices? I don’t see it here: https://www.smartthings.com/products

All is not lost though. It probably needs a custom DTH for it to join properly, OR you can use the ST Classic mobile app to add it. It may join as a “Thing”, and then all you may need to do is change the device handler to “SmartPower Outlet”.

There are tons of discussions in the community about how to use the IDE to make changes like that, and/or use your own code. Also good info here:

http://thingsthataresmart.wiki/index.php?title=ThingsThatAreSmart_Wiki
http://thingsthataresmart.wiki/index.php?title=Using_Custom_Code

1 Like

Thanks I have tried the ST classic and
It hasn’t worked which was a shame as it seems the easiest way
Making the plug a ST plug does seem quite hard but I will look further in to it

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.