Develco Zigbee smart plug shows as Z-Wave remote

I have a bunch of Develco SPLZB-131 smart plug with Zigbee protocol. I first connected one of these successfully in ST, and it showed up as “Zigbee Switch Power” and worked flawlessy. When I tried to add the other ones they all showed as “Z-Wave remote”. I then tried the different integrated Zigbee DHs with no luck, wondering if there was something wrong with them all but the first smart plug. So I disconnected the first working smart plug and reinstalled it and now it too shows as Z-Wave remote and won’t work.

Any hints to how to get these to work???

Go into the IDE SmartThings. Add a little smartness to your things. and manually change the device type ZigBee switch power.

Thank your for your suggestion. Yes I did try that but still it won’t work.

I got it to work by hard resetting the plugs and reboot everything.

Anyone knows how to activate TouchLink sync on the Develco smart plugs?

I am having the same problem - have two of these working fine, but when trying to add 3 new they all show up as z-wave remotes. I Have tried changing them to zigbee power switches in IDE - which changes them to switches in the smartthings app, but I am unable to turn them on/off. Have also tried resetting the plugs by holding the power-button for 15 seconds. Could you go into detail what your steps were to get them to work?

I don’t remember exactly how I did it, but I think I held the power button for 20 seconds or more. Then unplugged it right away. Then I plugged it in, added it to the network and it showed up correctly.

Seems to be exactly what i did, but it still wont work. Did you have to change the type in IDE after this, or reset the hub in any way? When you add the plug in smartthing, you just find it through researching for new devices, right?

I also have the exact same problem:

  • About 4 months ago I bought a 5 pcs of Develco SPLZB-131 smart plug with Zigbee and paired 1 of them successfully with ST.
  • Since the plug have been working flawless for these months I decided today to hook up also the other 4 plugs - and - surprise - they all show up as Z-Wave remote.

I’ve tried adding them using the suggestions above and tried using the Device Handler posted in another topic here at the forum - still no luck.

Is it possible that there have been som automatic firmware-update of the hub lately that have screwed things up?

The Z-Wave Remote handler has a fingerprint of just deviceId with the value 0x01. As Zigbee also has a deviceId available I guess it is possible that something has changed about the way fingerprints are matched and suddenly Z-Wave Remote looks the better bet.

@bentjh : Did you ever find a solution?

I actually got it working after fiddling around at SmartThings. Add a little smartness to your things. and eventually adding it as “Zigbee Metering Plug” It works ok now - I have 5 of these and they work fine.

Thanks! Is it an Edge driver or a DTH? @bentjh