Incredible difficulty connecting to either Z-Wave or Zigbee Devices

Hey all,

I am new to the Smartthings community but am hoping someone can help solve a problem for me.

Since purchasing my Aeotec v3 hub a few months ago I have had nothing but trouble connecting devices to it, whether they be z-wave or zigbee.

Most recently it took me a few days of exasperated troubleshooting to finally get some simple Zigbee smart outlets paired. My hub just refused to find the devices regardless of how many times I re-plugged them in, reset them, unplugged/rebooted the smart things hub and app, etc. I randomly decided to try one last time and lo-and-behold the smart outlet was discoverable and paired without issue. All in all, out of the 10 smart outlets I have tried (2 different brands) only 4 were successfully found by the Smart Things app and paired.

I am unable to get any devices to reliably connect the first time around. I even had to spend a few days troubleshooting my Z-wave smart locks before getting them successfully added.

I’ve contacted support and have a case open but have received no real help yet.

Any idea why my hub seems to struggle to find devices in pairing mode?

Many times you need to pair the devices right next to the hub. If you have not tried it, give it a try.

I’ve tried the devices at varying distances from the hub, in some cases less than a foot away.

Also some brands like Aqara can be very hard to pair with ST.

I’ve tried Sonoff and Third Reality brand outlets and 4 out of 8 Third Reality outlets did eventually become discoverable and work fine now, the 2 Sonoff outlets have yet to be discovered while in pairing mode.

Also, when you add, don’t just Scan for Nearby Devices. I’ve had better luck hitting the 3 dots menu then View supported devices, and find your brand and device, then try and add that specific device

check that there is no channel interference between zigbee and your wifi


Are the devices you are trying to connect ST compatible? If not, expect trouble.

The OP didn’t list all the models they are using, but one of the ones they did mention, the Third Reality smart plug, is certified through the Works With SmartThings (WWST) program, so that’s not the issue.

Indeed, did not notice the comment. The Sonoff one doesn’t seem to be supported.

Interestingly, although Sonoff is listed in the aforementioned compatibility list as a brand, they don’t have any compatible devices listed. I wonder why they are on this list.

I’ve been using their temp and humidity sensors without a problem, pairing directly with Aeotec hub. Their own web site still gives instructions on how to connect through their own app but it is not required, for these sensors at least. It is annoying as all redundant apps anyhow collect data, which is unnecessary and sometimes annoying or alarming from the viewpoint of the customer.

All in all, Sonoff doesn’t seem to belong to the list of compatible products if not really WWST certified.

Sonoff mostly makes WiFi devices and only a few Zigbee models.

The brand has a WWST certification for the cloud to cloud integration and that does bring in most of the WiFi models. (It may also bring in some of the Zigbee models that are connected to a Sonoff hub, I’m not sure.)

The page that you linked to is for the cloud to cloud integration, which is why it mentions the eWeLink app.

The official integration is at the account level, not the device level.

After binding successfully, all SONOFF devices that have connected with eWeLink will be synced to SmartThings.

It sounds like the issues the OP was having involved Sonoff Zigbee devices being connected directly to a SmartThings hub which is a different integration path. :thinking:

1 Like

Ok thanks for the explanation.

1 Like

I have tried both methods of adding devices and neither will recognize devices in pairing mode.

Can you explain how to do this?

With respect to the Sonoff devices, I went through their Amazon reviews, and every review mentioning the smartthings hub spoke of how easy it was to pair. It seems like my hub specifically has trouble pairing with devices, both Zigbee and Z-wave.

Yes, it did sound like you’d run into something major. :thinking:

There have been multiple reports in the forum from people having trouble adding devices of different protocols over the last six weeks, but I don’t know that any pattern has emerged, which is why I didn’t comment on that.

I’m sure it’s very frustrating, it just doesn’t seem like there are many community tips and tricks that can help right now. Official support can see more than we can, so hopefully they’ll find some thing to help.