Why are my temperature sensors showing "checking status"?

These are xiaomi temperature/humidity sensors. I initially installed some device handler and they were working perfectly. Suddenly some day they started showing this instead… Honestly pretty PISSED about it because everytime I spend x hours researching how to get something integrated into my home and are happy about it, it takes just one update and then things are not working again. Then I have to go here and find a solution and usually that takes additional hours of work and are quite frankly a pain in the ***… I never imagined the amount of maintenance for a smart home system would be within this scope… There are updates very frequently and if they would just keep backwards compatibility or be non breaking changes it wouldn’t be a problem. But after half a year owning a Samsung smartthings hub I have found myself investing soooo many hours maintaining and repairing integrations and automations… Lot more hours than I save when I don’t have to physically get up and toggle a light switch, etc. :roll_eyes:

I’m honestly feeling really frustrated about this because I do not sense that this is the normal experience from other smart home enthusiasts… When I read posts or watch YouTube videos it all sounds really nice but what I experience is definitely not what is being portrayed. Sorry for the vibe… Just needed to let this off my chest.

Back to the actual question. Any ideas why these sensors are showing “checking status” and not just the temperature that it reported? When I tab on it and go to its view I can see that it is in fact reporting temperature and humidity so why does it not just display that at the home tile view?

1 Like

A known problem. Change your system language on your phone to english and it works. Please report this to Smartthings support so we can get it fixed

As a test… if you want to try. Change the language on your mobile device to US English and see if they work properly.

Thanks for the very constructive help :slightly_smiling_face: how should I report it? As an official support ticket?

And btw, changing the langues in fact did work

13° in my fridge is something I should be worried about though. I don’t think that sounds good :sweat_smile:

This is ridiculous… Again… @blake.arnold

1 Like

Yes, we need to bring focus to this problem. If more people report it they may actually look at it

Thanks, as always, for the heads up. This is being actively worked on by our devs. We’ve determined the root cause and are testing the fix now.


Hi, almost two months since you’ve “determined the root cause and are testing the fix now”… And the issue is still there.


This is getting a bigger issue now as you forced us to move to the new smartthings app. It worked well with the classic app, but still no way to make it work in the new app. I’m glad I’m moving my things to my Hubitat, it works way better, smoother, locally, and most of all when an obvious issue like this one is addressed it does not take months for it to be resolved.

This is still a problem, and no changing the language did not fix it. This is crazy.

Any updates on the fix that is being tested?

I see the same behavior, but in addition some devices shows as disconnected even though I can use them, and many of the devices, especially the ones with custom DHT show the incorrect main tile/value. The new app really feels like a downgrade from the old app.

The forced transition to the new app is forcing me to move my sytem to Hubitat after 2-3 years of Smartthings…

I added an Aqara temperature & humidity sensor a few days ago and since I got a “checking status” delay whenever I started the ST app.

I changed the language on my phone (IOS 15.2) to English (US).

This is an insane FIX! But it worked (sort of). I still get the “checking status” delay sometimes on app start but the delay seems shorter).