"My Apps" is missing from Marketplace, SmartApps?!


(Dale C) #1

I am unable to install a custom smartapp any more because in Marketplace under the SmartApps tab I no longer see “My Apps” at the bottom anymore for installing them? They all show up in my IDE just fine. I am using Android, iOS and WindowsPhone and I can’t see it on any of them.


Help with adding new smart app
TP-Link/Kasa Bulbs and Plugs Control
(Greg) #2

I see it on my devices. If you never had it before. you might need to log out and back in. Not sure if they ever fixed that but that is what you used to have to do when you publish your first app


(Dale C) #3

Nice idea, I logged out and in and still nothing. I will try rebooting the hub… I have a ver2 hub and I don’t know if there is an easy way to reboot the hub without taking off the power and removing batteries?


(Greg) #4

There is a button on the back


(Dale C) #5

The button tip was great. AND it brought back the My Apps :grin: Thanks for your help!


#6

I had this say issue. Support finally resolved it. I also had an issue where I wasn’t able to log into the developer IDE and see the developer tabs. So, maybe my issues was a bit different.

I didn’t know about the button on the back of the hub. I will have to keep that in mind if I get this problem again.


(Josh) #7

Can you provide any details on how support fixed your problem? I am missing the My Apps category and the solutions I’ve found do not seem to work. I’m hoping im missing something simple…


#8

Have you published any custom apps to yourself? You can look in your account on the IDE to see if there are any there.

If you only published apps from the marketplace section, they will show up in a different area. For those, click on the checkmark icon at the bottom of the screen that says “automations.” Then you’ll see a page that has two tabs at the top, one for routines and one for “smart apps.” That’s where you’ll find the official smart apps like the Hue connect integration, smart lighting, the Amazon echo integration, the harmony integration, etc.

The only app that show up under “my apps” are ones that you published to yourself as raw code through the IDE.


(Josh) #9

I added the nest-manager smart app following the procedure in another thread. The code is published and it actually assigns the category to “Convenience” but I don’t see that button either. The instructions eluded to going into My Apps but no matter what I do, it never appears.


#10

I would ask in the authors thread for that particular app. There may be an additional step you have to do.


(Greg) #11

I’m not sure if it is still the case, but a long time ago you had to log out and back in on the mobile app to make “my apps” show up.


(Alborz Amini) #12

Any success with the nest app? I published the app for myself, but logging out and restart does not help.


(Dale C) #13

Two thinks to [quote=“Joshcorp, post:7, topic:41369, full:true”]
Can you provide any details on how support fixed your problem? I am missing the My Apps category and the solutions I’ve found do not seem to work. I’m hoping im missing something simple…
[/quote]

Two thinks to try

  • Reboot the hub

  • Make sure the account you are signed in with is the primary account.
    I have multiple accounts slaved off my primary email which is the way tech support had me configure the login for each of the family members. If you have multiple simultaneous login’s using the same account can cause problems. Only the primary account has access to the My Apps not the slaved accounts, at least that is the way it was a while back.


(Aaron S) #14

there is a “developer feature” associated with the account account when you first sign into the IDE. There are some instances where it can become removed. Try totally logging out of the IDE and app, and then logging back into both. If that doesn’t do the trick, shoot a note over to support@


[REMOVED] Nest Manager 4.0
#15

I shoot an email over to support yesterday, so far no feedback yet


(vlad) #16

Could you try what was recommended in this post?

That is likely your issue if you recently purchased a new hub and are using https://graph.api.smartthings.com for publishing. The correct URL for new hubs is https://graph-na02-useast1.api.smartthings.com/ in the US or https://graph-eu01-euwest1.api.smartthings.com/ in the U.K. You’ll know right away which URL is the right one if you see your devices on the devices page. Please DM me your username if that doesn’t fix it for you.

Thanks and apologies for the trouble!


#17

Cool, the na02 works! Thanks!


(Oficina) #18

had same issue, i had to use https://graph-na02-useast1.api.smartthings.com (im using hub ver2) as vlad pointed out from somebody else´s post… vlad and the other guy are life savers, thank you guys


(Micah Gehman) #19

How I got My Apps to show up after setting up my first app using a Youtube video for the Nest Manager

  1. In the IDE (the website), click My SmartApps at the top
  2. Under the column Namespace/Name click the title - tonesto7 : Nest Manager
  3. Click the Publish button and it will immediately display My Apps appropriately in your phones app.
    Note: When originally following along with the video, I didn’t check the box for Publish. I went back and checked it when I realized I had got ahead of the video’s author but I think at that point it’s too late and must be done with the above steps.

#20

This doesn’t work for me - My SmartApps isn’t showing up so I don’t think I can add any custom ones - such as Morgan freeman Sonos notifications as I can’t see them in the phone app. When I log onto the smartthings website and see My locations my devices etc it has my locations but doesn’t show my hub or any of my devices. Not sure if that’s relevant.