What happened to PUSH notifications in new app?

I use Webcore for a lot of PUSH notifications when certain contacts open.

I started using the new Smartthings app and I stopped receiving them.
Webcore still seems to work though.

1 Like

Edit your pistons to

Send push notification (msg) and store in messages

Yeah, i did.
That’s not working. I also went into the settings and made sure I allowed notifications.

Are you receiving messages on your phone?

I get the messages under the message section the Smartthings app.
But I do not get the PUSH notification on my iPhone.

Go to SmartThings settings, than enable notifications, and you can even click on notifications and select specific device notifications

2 Likes

I thank that was it, idk how I missed that.
Thanks a lot!

I have both the Classic and New app installed and (correctly) get Notifications from both for my devices, however, I don’t get Push Notifications from a command triggered within a Piston. I checked the Notifications section in the new app and see that they’re enabled for all devices.

You will need to edit your pistons and change send push notifications (msg) to send push notifications (msg) and store in messages. Click on the push notification command in the piston and Set store in messages to true.

1 Like

Thanks, that worked!

This fixed it for me

Thanks for this, this helped me as well :slight_smile:

This didn’t work for me :cry:

I have a piston that I created after the migration (accidently deleted webcore and all my pistons so started from scratch) that used to work, and still sends the Push notifications as desired to my wife’s phone, but just stopped sending them to my iphone. Any ideas?

if the push notifications are sent to your wife’s phone and not yours… sounds like a permission setting. on your iphone, go to settings, scroll down to the smartthings app and check if notifications are enabled. if they are enabled, optIon two would be to uninstall/reinstall the app and see if push notifications start working. note - uninstalling the app will lose any dashboard arrangements you have made previously.

Iphone settings were already correct. Deleted the app, re-installed, seems to be working :man_shrugging:

This whole forced migration has been a nightmare. Now if I can get Alexa working right again, I’ll almost be back to where everything works like it did just fine before. Thank you so much for your help.