New Smartthings App - push notification issue

Hi,

Recently I realized that push notifications do not come from the ST app.
Only the “hub disconnected” & “hub connected” notifications are coming.

But I have other notifications from smart apps that should be getting triggered. Mostly Core pistons but others as well.

is this a common/known issue ?

any fix ?

Did you adjust all your webcore pistons after the classic app was shut down

Previously you could use the following in pistons when the classic app was available:

Send push notification (msg)

But that no longer works with the new app so you will need to edit any pistons to the following:

Send push notification (msg) and store in messages

So edit the pistons and set store in messages to true for the send push notification command.

1 Like

thx @jkp
well, I didn’t know that.
but what is the difference between these 2 functions ?

and what is the difference in groovy code for these 2 functions ?
because I have other custom apps that use push notifications and I don’t see an option to store messages in them. I also have my own simple apps that use push notification.
I would like to make the change in groovy code so that all my apps can send push notification.

sorry, i can’t help with custom code.

tagging @orangebucket @johnconstantelo

1 Like

@jkp , @orangebucket @johnconstantelo

if the difference is sendPush(string) and sendPushMessage(string) , then I tried both with no success.
None of these make a notification on phone.

btw, I don’t see any notifications also in the “messages” section of the app.

sorry, i should clarify that my post was dealing with webcore. i know you had mentioned CoRE so not sure if that is where i caused confusion.

actually I am using also Webcore and other smart apps.
None of them can show notifications on my phone.

I tried “store message” option on Webcore.
it also does not work.

Besides, my Smartthings app does not display any messages under “Messages” section (other than hub connected/disconnected)

so I believe my app can not receive messages.
what causes this ?

you might try uninstalling/reinstalling. note: doing this will cause your dashboard to rearrange upon login.

can you post a image of one of the pistons you edited?

I’m just uninstalling now and trying other things.
this is not about Webcore or Core or any specific smart app.
ALL of my smart apps fail to send any push notification to the app.

That is indeed the way webCoRE differentiates between sending push notifications and also ‘storing them to messages’. To just ‘send a notification’ it uses sendNotificationEvent(). Notify Me When uses sendNotification(), letting it default to also sending the notification event (the same thing as storing as a message).

It seems like the new app is only working with notification events, and has no interest in the legacy push notifications.

Something you might like to try, but equally might be a pointless suggestion, is to look at your notifications via the REST API. In Curl command line speak it is:

curl --header "Authorization: Bearer <Personal Access Token>" https://api.smartthings.com/notification

(visiting https://account.smartthings.com/tokens for a token with Notifications scope).

It doesn’t seem impossible that the notifications might be in the feed but not get acted on by your app.

thanks.

I also tried with the curl command you suggested. It returns only last 4 notifications and they are all “hub disconnected” and “hub connected”
no other notifications.

I’m going crazy. What happens to my notifications ?

Btw, you confirmed my post about sendPush() but then you said sendNotification()
which one is correct ?

Interesting. I was kind of hoping we’d see all the notifications there and be able to point a finger at the app. Not knowing the architecture I am not sure what it means though.

Is it just notifications from legacy apps that aren’t appearing?

webCoRE uses sendPush() and sendPushMessage() for sending push notifications, and sendSms() and sendSmsMessage() for SMS, the second form being used when the ‘Store in Messages’ option is selected. It also has a ‘send a notification’ command which just uses sendNotificationEvent() (which is like the ‘store in message’ without either push or SMS).

The sendNotification() method is used by the Notify Me When app to send either push notifications or SMS messages or both. It always sends notification events, but they can be turned off when the method is used elsewhere.

it’s like my app is not accepting notifications.
or my account ?
is there any such setting on Samsung account ?

I’ve changed my codes to use Pushover instead of Smartthings notifications.
This will cover all my custom apps , including Webcore

I’m not sure what other notfications I miss because of this silly problem.
is there any other important notifications from the ST app ?