WeMo unable to repair (Solution)


I’ll cut a long story short but I was having problems with a WeMo bulb going offline lots since around Christmas time, it was stable until then but it looks like the source is a neighbours wireless affecting it based on channel scanning, probably a new xmas present!

Anyway, I have removed the bulb from the affected area, only 1 area of the house picks up this neighbouring signal.

Anyway decided to delete and re-pair the bulb in a new socket, but it will now not pair with the hub.

Resetting the bulb is successful, and the light even blinks twice when doing a discover to show it is found but it never appears in the app to name and pair.

I thought it may have been faulty but I broke out the old WeMo link and this can see and pair successfully.

My thoughts are perhaps the hub has held on to the device address somewhere and I could check in the ide, but I can’t see anything in the logs.

Anyone have similar problems or can offer me additional things to try.

Btw my other 3 bulbs all work solidly with the hub



Ok I think I finall solved it!

The light was called Back Porch and this was still remembered in the Alexa smart app, even when I reran discovery after deleting the device and resetting it.

Manually forgetting the device in the app allowed me to add the device again.

However, this did not solve the issue completely.

My device was recognised now but operating the light was hit and miss, sometimes it would respond to on/off other times (as in most times) it would get stuck in the turning on/off phase and not affect the device.

A quick look in the IDE shows it had been recognised as a zigbee dimmer, the same as all my other bulbs. I changed the device type to WeMo bulb and it now works reliably.

I also experimented and changed the type to zigbee dimmer power and this worked as well, but going back to the original resulted in inconsistent operation.

Why it will not work as the same device type as my other WeMo bulbs I don’t know, especially as before my issues it was also classed as a simple zigbee dimmer.

Another odd thing is it shows as offline in the IDE, despite the app showing status updates and operating the device. Integration with Alexa and a harmony hub also continues to operate.

I’m not going to investigate these odd issues any further as it now appears reliable after a couple of hours.

Just thought I would post back in case it helps someone else.