SmartThings Community

WeMo Switches & SmartThings


(Tom ) #1

Hi - I have been fighting a problem with my WeMo Switches executing their rules exactly one hour late, i.e. instead on coming on per the rule at 5:00 PM, they turn on at 6:00 PM. While it seems like a simple time zone or setting problem, we have checked everything and the time settings appear correct. In trouble shooting the problem, I removed the switches from SmartThings and my problems seem to have disappeared, but it is too early to tell for sure. Has anyone else observed weird behavior from WeMo switches that have been integrated into SmartThings?


(Tom) #2

Have you checked the time on your router?


(Bob) #3

I have a Switch and an Insight integrated with ST.
I do not use the WeMo app for anything apart from initial provision.
I don’t have any issues with CoRE pistons firing at the wrong time.
Sorry not much else to say.


(Tom ) #4

Yes, we’ve checked the time setting on all network devices as well as the firmware levels. No network connected device that we can find shows a wrong time. We have been using rules created with the WeMo app on a single iPad and those rules show as currently active at the proper time. However, the switches don’t turn on until 1 hour after the rule goes active and they turn off one hour after the rule ceases to be active.

Removing the switches from SmartThings seems to have corrected the problem.


(Tom ) #5

Bob - what are you using to trigger the switches on & off?


#6

I had similar issues with rules set using the Wemo apps, and it has been brought up at the wemo forum.

My recommendation is that you stay away from using the native wemo rules. Use either the smartthings or IFTTT integrations to schedule your wemo. Both integrations have been working fine for me without major issue.


(Bob) #7

I use the CoRE smartapp in ST.
I gave up on the WeMo app over a year ago. I found it unreliable and every time there was a clock change in the spring or autumn, the clock would not update and caused no end of issues.
Have you gone through a clock change recently or did it start after a clock change?
They also kept going AWOL in the WeMo app.
That was the initial reason for my ST hub purchase.
Have you tried CoRE?

EDIT: If you only want to set up simple rules, have a look at Smart Lighting. You will find it through your mobile app under market place and lighting.
This may be all you need.


#8

I had the same issue with my wemo switches and additionally, the “long press” rule would not trigger unless the switch was long pressed twice. I assumed this was a wemo issue and contacted wemo support. The next day a fw update was pushed to all my wemo devices and everything started working as expected… I was told by wm support that because I was using the beta version of their android app they were able to push a beta version of the FW to my devices. They didn’t explain what caused this or how the FW update fixed the issue but they are aware it exists.

I still use the wemo rules in the event that the ST hub is offline and the wemo switches remain connected to the internet but, I also use core to check if the rules executed successfully.


(Bob) #9

Is that belt, braces AND string? :wink:


(Tom ) #10

Bob - Thanks for the info. I am areal newbie with regards to ST. I have a handful of sensors that I monitor but have not gotten involved yet with routines or apps. As such, I have not used the CoRe app, and was unable to find which one you were talking about. I did find the Smart Lighting app within the market place and plan to try it with the WeMo switches. My case with WeMo has been escalated through three levels and I am now supposedly working with their engineering staff. I plan to ask them about ST integration from their perspective.

Regards - Tom


(Bob) #11

If you only want to do simple straightforward rules, Smart Lighting is more than adequate.
When you want to do more advanced things you may want to use CoRE.
Here is some information about it.


(Tom ) #12

David - Thx for the info. I have been using the WeMo app for all rules and would then check recent notifications with ST to see if the lights turned off at 1 or 2 AM. It sounds like I need to dump the WeMo app for making rules.

Best Regards - Tom


(Tom ) #13

Thx, Bob - I’ll go through this!


#14

I’ve been through this. My Wemo App-based rules were fine for months then I started getting random issues with the rules after one of the recent fw updates - one day they wouldn’t work on some devices then another day it would be different devices. And I have had the one hour off thing frequently.

I dumped all my Wemo-based rules and set them up in SmartLighting in ST. Much more control and then CoRE provides even more if you want it.

I also have the long-press issue someone mentioned above - having to press it twice so I gave up on Wemo rules altogether.


#15

Do you know how to set up a long-press trigger in core using the wemo switch? I know there is a long press attribute for buttons but I wasn’t sure how to do that with a switch.


#16

I’d think you’ll need a custom device type for it to work. Have you tried it thru IFTTT to see if the issue goes away?


#17

Honestly, I don’t. I should have been clearer and stated I have not replicated that rule in ST. Given CoRE does not run local I’m not sure if it’s feasible. You’re also looking at Belkin’s cloud talking to the ST cloud and even tiny delays can mess with something like that. Try posting in one of the CoRE peer threads …


(Tom ) #18

Thanks for all of the help. I added my switches to ST and the used Smart Lighting app to program them to turn on & off. All seems to be working fine!

Now to try & understand Github and CoRE!

Thanks again!