WeMo Motion, does it work for you with ST?

Just wondering if anyone has a WeMo Motion that is working 100% with ST?

I’m new to ST, my WeMo motion sensor drops off the ST system after approx 2hrs, I see Joe’s post mentions the same (link below). I would say it falls asleep, but it’s not my WeMo motion (during this time it shows perfectly on the WeMo App), it’s the ST App / and even in ST IDE log it stops showing communication from my WeMo motion.

If I go into the ST “Things” and click on refresh for my WeMo Motion then ST starts talking to it again (for an hour or so).

I emailed ST Support and they said they will look into it. Just wondering what your experience is.

1 Like

I seem to be having the same problem as well. Just noticed it yesterday. Wonder if it has to do with any recent wemo firmware updates?


Please let support know. I emailed them but if you would let them know that you are having problems as well now. I have only had my ST system for about a week now, first couple of days my WeMo Motion seemed to work fine but not now. Maybe include this link when you email support.

I’ve had that problem for months. I gave up on the WeMo entirely. My other motion detectors (ST and Aeon) work perfectly.

Just in from Support:

About 30 mins ago, QA push improvements to Wemo to the production level. The push was via cloud, so once the hub is hooked back up and talking with our servers, it should benefit - no extra action should be needed on your part. When you get a free moment, if you could share any insights it’d be greatly appreciated. Thanks!

SmartThings Support

The QA push improvements don’t seem to improve my WeMo Motion. ST still stops talking to my WeMo Motion approx 70min after I last refreshed the WeMo motion in the ST “Things”.

Hopefully they can get it fixed.

No change here either. According to ST my Wemo motion always detects motion and stays stuck in that mode in the UI. It seems to strangely process actions when movement is detected

For the past 3 or 4 days my WeMo Motion has reported on the ST Log every 20seconds or so just like it should! Before the weekend I deleted everything related to WeMo on my ST and then put it back on… Working great SO FAR!

Thanks, Dave. I’ll bring out of retirement and see if it works for me. One question though - I’ve never been able to delete the WeMo Connect app from Labs. Did you do that as well? If so, how?

After I went around to every light and my WeMo switch and unconnected them in the ST App, then I believe I just used the “Uninstall” at the bottom of Labs.

I have 18 wemo motions , switches in total so that is a weekend activity for me. Also I need to recreate all the rules :frowning:

It was quicker and easier than I thought, even my bulbs are working better now.

Dave thanks for the encouragement :wink: I went ahead and did it had to remove all smartapps and switches and then add them back
It’s not a 100pc but it has solved many of the problems like the wemo motion stuck in motion mode and switches not reflecting right statuses or just not plain working. If you have wemo’s then you really need to do this to make it an awesome experience



After yesterday’s cloud trouble, today my WeMo Motion is not talking to ST 100%, jus like a month or so ago. Time to uninstall then reinstall it again I guess… Pain in the but! I just did the same for my GE Link bulb.

Did your ST stop talking to your WeMo Motion today?

yup same thing. I actually go into the “Wemo smartthings” connect app and wait for it to do a bunch of rediscovery cycles and the switches and plugs work but not the motion. I guess wait for a day and hope it all comes back , I’m tired of removing stuff and adding it back :smile: Also last time some of the issues just fixed themselves. Also I’m holding on to not updating the Wemo’s to 7166?? which is the latest firmware update as the previous firmware version worked great prior to all this. I’m gonna reboot my hub today and see if that helps.

I added some of the linear zwave switches for dimmers and wow they make a difference , no issues like the wemo’s , not looking back but stuck with the existing wemo’s I have

My issue with the sensor is that it does not seem to refresh.

When I examined the sensor activity under my devices, it seems to indicate it was last active 5 days ago.

When you click on REFRESH in the WeMo Motion tile does it start to show up again in the IDE log? Maybe for around 1hr then stop again?
But works perfectly fine with the WeMo owned App.

Exactly what happens. Works fine in the WEMO App itself but needs constant manual refreshing within ST

Yup! ST is well aware of this and I emailed WeMo to nudge them to work with ST to get this stuff to work correctly. Maybe if enough people email them they will work something out.

If you uninstall your WeMo then reinstall it it should work correctly for a month+.

Unlike my ST motion sensor I have never had a false alarm with my WeMo Motion sensor and the updating is fast (20sec).