WeMo Motion, does it work for you with ST?

I noticed that this thread went quiet in December. Did you guys find secret sauce for getting WeMo Motion sensor working reliably? I’ve deleted/re-added, lived through a few firmware updates and have consistent IP addresses but still struggling with our wemo motion sensor (wemo switch is OK) - I can ‘refresh’ to bring it back to life, but it doesn’t seem to last. I’m new to ST and this discussion board - have I missed something or am I looking in the wrong place?

any/all guidance would be appreciated

Once in a while, maybe every other month I have to uninstall my WeMo Motion then reinstall it. Hitting refresh only does it for about one hour.
This last time my WeMo Motion was working great for at least one month then my electric went out twice in a 5 minute period. When my electric came back on my WeMo motion was not working, the next day I had to uninstall and reinstall.

Of course you have to redo the SmartApps associated with the WeMo Motion each time. If you have a second non-WeMo motion sensor move all the WeMo SmartApps over to it first then uninstall the WeMo. After reinstalling WeMo move the SmartApps back. Easier and faster this way.

Thanks Dave, Very Interesting. I seem to get same results with uninstall/reinstall (even if delete/re-add ALL WeMo devices) as I do with refresh - detects motion for an hour or so, then nada. Been putzing with it for about a month, haven’t been able to get it to work reliably at all

I think I’m up to date on firmware and such - ST hub v1 (US), v=000.013.00013, WeMo_US2.00.7166.PVT.

I’ll try the support route - and include a link to this thread - perhaps I can get you an update, looks like you reported it quite a while ago.

Tom and @Dave-- one idea to try might be using the new version of the pollster app which now supports refresh() as opposed to just poll(). I’m giving it a shot now to see if a 30 min auto-refresh cycle will keep my wemo motion alive. I’ll let you guys know how it goes, but it probably wouldn’t hurt to give it a shot given how annyoing this whole WeMo thing is to begin with.


1 Like

Thanks V - keep us posted

I re-emailed this topic to ST support this morn after a major re-do this morn - pretty much reset everything to factory and reinstalled my world. WeMo motion worked for a little while, then stopped

I simply asked support group if we are missing something - also to see if they are working on it or need any additional info. I’ll also post updates.

Sent to Support@ yesterday right after my post here. They were going to point engineering to this thread - I doubt it’s even on a defect list @ this point. No apparent Trouble Ticket or Reference # on the response from support, but ST activity on this may get linked to https://support.smartthings.com/hc/en-us/requests/80565 (My original report)

Oddly - my WeMO Motion appears to be working - still this morning. By FAR a new world’s record for me.

Vishad - I now see a resync every 30 (approx 29+) minutes in the device events … and have a working WeMo Motion detector - for 2 days in a row, at least?

I took a peek at ALL “events” for the WeMo Motion Device and see a pair of commands every 29 seconds:
an APP_command/refresh with Displayed Text="Wemo (Connect) sent refresh command to WeMo Motion"
followed by
a command/refresh with Displayed Text=“refresh command was sent to WeMo Motion”

I can’t go back far enough in logs to see if this was happening (and failing) prior to my major reset/reboot on Monday. But, the gizmo is working

I just found it interesting - I still need to dig in and see how apps like pollster work

So far seems to be working really well for me too!

Mine WeMo motion went back into the ditch a few days ago - a new record for me, the ‘thing’ worked for 10+ days. I tried the delete/re-add/resync dance, but to no avail. From ST hub perspective, it works for a few hours then drops out of sight. If I look at it via the Belkin app, its working fine. Not really in the mood for a factory-reset/reboot again and really doubt ST can get a handle on this.

I’ll finish my testing, but now looking for alternatives to ST - its waaaay to wobbly and hard to use (especially for muggles, like my wife!). Not just because of WeMO, just overall. If I’m going to have to code this stuff, I’d rather do it on an open source hub/platform if I can. Has anyone had any luck with any? Perhaps Rasperry PI based?

Yup… All my wemo devices are pretty flaky under ST. Totally unreliable. I have wemo motion, socket, switches and insights. None are better or worst that others.

I have the same problems whit my WeMo Switch it change ports and the ST dos not do a ting. you have to uninstal and then install the wemo again :persevere:

I only had one for a while (motion) and it worked nicely. As soon as i added a second both didn’t work for more than ten mins. What a waste of cash.

Can you publish your method of 30-min auto-refresh? I would like to give a try. But, don’t know how to implement auto-refresh. Thanks.

He is using the SmartApp “Polster”. The “Refresh” parameter is an option under the Preferences of the app.

Even with pollster I got less than a day out of the wemo working with smartthings! Anyone else with other ideas?

My pollster stopped working a couple of days ago. Which means my WeMos stopped working as well.

I came here to see if I too could add a 30 min refresh. From reading this post I’m really disappointed. Myself and so many others I’m sure had wemo’s before we invested in ST and now we just can’t use them despite all the advertisement stating full compatibility. I’m trying hard to not get discouraged by ST because I held out for so long for the V2/UK release. Just a month ago I stopped myself from buying a Vera lite.